Bug 52583 - ContentEditable is not available on Mobile WebKit
: ContentEditable is not available on Mobile WebKit
Status: RESOLVED INVALID
Product: WebKit
Classification: Unclassified
Component: HTML Editing
: 528+ (Nightly build)
: Other Other
: P2 Normal
Assigned To: Nobody
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-17 09:21 PST by Frederico Caldeira Knabben
Modified: 2011-01-20 01:40 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frederico Caldeira Knabben 2011-01-17 09:21:57 PST
A simple contenteditable enabled page like the following doesn't work on WebKit Mobile:

---
<html>
<head>
    <title>Simple Editable Page</title>
</head>
<body contenteditable="true">
	<p>This is some text with a <a href="http://google.com/">link</a>, which should not be active but editable.</p>
</body>
</html>
---

I'm testing this on an iPad with iOS 4.2.1 and Safari.

Current Results
===============
The page opens like a normal page, but it's not possible to place the caret on it and start typing. It just behaves like a normal page.

Expected Results
================
The user should be able to tip on the text. The caret should start blinking at the tip position and the virtual keyboard should appear, so the user can start typing.

This issues makes it impossible to develop browser based rich text editors, like CKEditor, targeted to WebKit based mobile devices.
Comment 1 Alexey Proskuryakov 2011-01-17 17:08:09 PST
Please file iOS WebKit bugs via <http://bugreport.apple.com>. We cannot track them in Bugzilla, because iOS WebKit isn't built from webit.org sources directly.

Similarly, Android bugs should be reported via their bug tracker.
Comment 2 Frederico Caldeira Knabben 2011-01-18 07:57:19 PST
Thanks for the input Alexey. I've expected someone driving me to the proper place in fact.

Just for reference, I've reported it to Apple with Bug ID# 8878775.
Comment 3 Frederico Caldeira Knabben 2011-01-20 01:40:39 PST
Just to keep the reference updated, my Apple bug has been marked as duplicate of Bug ID# 5245015.

I have no visibility of that bug, so there is no further information to add.