Bug 52518 - REGRESSION (r69237): Black border around map elements while using an image map on Mac platform
: REGRESSION (r69237): Black border around map elements while using an image ma...
Status: RESOLVED FIXED
: WebKit
Layout and Rendering
: 528+ (Nightly build)
: Macintosh Mac OS X 10.6
: P1 Normal
Assigned To:
: https://bug-52518-attachments.webkit....
: HasReduction, InRadar, Regression
: 45832
:
  Show dependency treegraph
 
Reported: 2011-01-15 12:56 PST by
Modified: 2011-04-02 20:29 PST (History)


Attachments
issue image (22.55 KB, image/png)
2011-01-15 12:56 PST, Darth
no flags Details
testcase (479 bytes, text/html)
2011-02-11 10:03 PST, Darth
no flags Details
Patch (68.14 KB, patch)
2011-04-02 16:52 PST, Andy Estes
oliver: review+
Review Patch | Details | Formatted Diff | Diff


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2011-01-15 12:56:15 PST
Created an attachment (id=79073) [details]
issue image

This issue seems to happen on webkit nightly and chrome on a mac (does not happen on windows for either, haven't tried chrome linux).
This issue doesn't happen on Safari 5.0.3 or Firefox on the mac.

Downstream bug http://code.google.com/p/chromium/issues/detail?id=68487

The test url above shows the issue, click on the circles and a black border is seen.
See the attached image.
------- Comment #1 From 2011-01-15 12:58:57 PST -------
Also, in that test url, if you remove the css border and outline properties, clicking circles shows the normal focus border, which is correct, and no black border is seen.
------- Comment #2 From 2011-01-19 17:13:01 PST -------
<rdar://problem/8889770>
------- Comment #3 From 2011-01-19 17:38:50 PST -------
Looks like this regression is due to http://trac.webkit.org/changeset/69237.
------- Comment #4 From 2011-01-26 17:52:14 PST -------
I can also reproduce this issue by tabbing through the areas, although behavior exists in shipping Safari 5.
------- Comment #5 From 2011-01-26 17:55:53 PST -------
yea it's pretty reproducible
------- Comment #6 From 2011-02-03 16:51:22 PST -------
Another site affected by this bug is http://www.conduit.com. Click the tabs labeled 'Create apps yourself', 'Promote & optimize', etc. to see the bug.
------- Comment #7 From 2011-02-11 10:03:09 PST -------
Created an attachment (id=82141) [details]
testcase

Adding a copy of the test case from the url since the old one was modified by it's original author to do a blur() onclick. So the issue wasn't being seen in the url.
------- Comment #8 From 2011-04-02 16:52:36 PST -------
Created an attachment (id=87989) [details]
Patch
------- Comment #9 From 2011-04-02 17:01:46 PST -------
Committed r82781: <http://trac.webkit.org/changeset/82781>
------- Comment #10 From 2011-04-02 17:02:07 PST -------
(From update of attachment 87989 [details])
View in context: https://bugs.webkit.org/attachment.cgi?id=87989&action=review

> Source/WebCore/rendering/RenderImage.cpp:353
> +    

Might want to get rid of the whitespace added here.
------- Comment #11 From 2011-04-02 17:03:29 PST -------
(In reply to comment #10)
> (From update of attachment 87989 [details] [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=87989&action=review
> 
> > Source/WebCore/rendering/RenderImage.cpp:353
> > +    
> 
> Might want to get rid of the whitespace added here.

I did before I landed.