Bug 52462 - tweak line selection in code review tool
Summary: tweak line selection in code review tool
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other OS X 10.5
: P2 Normal
Assignee: Ojan Vafai
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-14 11:39 PST by Ojan Vafai
Modified: 2011-01-14 14:01 PST (History)
4 users (show)

See Also:


Attachments
Patch (4.97 KB, patch)
2011-01-14 11:42 PST, Ojan Vafai
abarth: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ojan Vafai 2011-01-14 11:39:02 PST
tweak line selection in code review tool
Comment 1 Ojan Vafai 2011-01-14 11:42:01 PST
Created attachment 78970 [details]
Patch
Comment 2 Adam Barth 2011-01-14 13:42:59 PST
Comment on attachment 78970 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=78970&action=review

I'm not sure I quite follow 100%, but this looks fine.

> Websites/bugs.webkit.org/ChangeLog:14
> +        -Make it so that if you click on the line immediately above
> +        a line that has a comment it will add a new comment instead of
> +        adding lines to the following comment. If the last selected line
> +        overlaps existing comment lines though they will still get
> +        added to the existing comment.

Interesting.  That's a nice refinement.  One thing I'd like to do better is if you drag select a bunch of lines and then move your mouse backwards, you should "unselect" some lines.  Currently, once selected, there is no unselect.
Comment 3 Ojan Vafai 2011-01-14 13:58:25 PST
(In reply to comment #2)
> (From update of attachment 78970 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=78970&action=review
> Interesting.  That's a nice refinement.  One thing I'd like to do better is if you drag select a bunch of lines and then move your mouse backwards, you should "unselect" some lines.  Currently, once selected, there is no unselect.

Oh. I thought that was by design. I'd be happy to fix this.
Comment 4 Ojan Vafai 2011-01-14 14:01:10 PST
Committed r75816: <http://trac.webkit.org/changeset/75816>