Bug 52245 - -webkit-transition should animate properties whose values are not explicitly set
Summary: -webkit-transition should animate properties whose values are not explicitly set
Status: RESOLVED DUPLICATE of bug 16020
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
Depends on:
Reported: 2011-01-11 13:08 PST by boucher
Modified: 2011-01-11 20:13 PST (History)
2 users (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description boucher 2011-01-11 13:08:47 PST
CSS Transitions should be able to animate all animatable properties, not just ones with explicitly set values. Right now those properties are excluded from any transitions. 

Things like dimensions and x/y coordinates that are computed in the normal process of laying out the page would be very useful to animate, and would enable some fairly advanced interfaces to be created without the use of javascript. You could imagine something like adding an element to an NSCollectionView. Right now you can do all of the layout without needing to set many explicit values, and definitely without the need to compute them in javascript. But if you want to animate the new element in, say by growing the container, or by shifting the other elements to the right, you must go back in and actually set those values in javascript so that transitions can then be used for the animation.

I could imagine just allowing the "all" value to include properties with "auto" values, or perhaps another keyword could be added like "auto" or "all-auto" so that the current behavior could remain unchanged and this would be an optional feature.

I looked around to see if there was discussion on this issue and didn't find any, but feel free to point me towards any I might have missed.
Comment 1 Simon Fraser (smfr) 2011-01-11 20:13:01 PST

*** This bug has been marked as a duplicate of bug 16020 ***