Bug 52104 - Would like script debugging protocol method to differentiate between caught and uncaught exceptions
Summary: Would like script debugging protocol method to differentiate between caught a...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit API (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh All
: P2 Normal
Assignee: Darin Adler
URL:
Keywords:
: 48598 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-01-07 23:06 PST by Darin Adler
Modified: 2011-01-19 19:14 PST (History)
4 users (show)

See Also:


Attachments
Patch (9.83 KB, patch)
2011-01-07 23:10 PST, Darin Adler
no flags Details | Formatted Diff | Diff
Patch (9.79 KB, patch)
2011-01-08 12:08 PST, Darin Adler
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Darin Adler 2011-01-07 23:06:36 PST
Would like script debugging protocol method to differentiate between caught and uncaught exceptions
Comment 1 Darin Adler 2011-01-07 23:10:15 PST
Created attachment 78306 [details]
Patch
Comment 2 WebKit Review Bot 2011-01-08 01:18:55 PST
Attachment 78306 [details] did not build on mac:
Build output: http://queues.webkit.org/results/7451028
Comment 3 Darin Adler 2011-01-08 12:08:53 PST
Created attachment 78326 [details]
Patch
Comment 4 Joseph Pecoraro 2011-01-18 13:43:15 PST
*** Bug 48598 has been marked as a duplicate of this bug. ***
Comment 5 Joseph Pecoraro 2011-01-18 19:00:06 PST
Looks good to me. I'll let someone more familiar with the area review it. I think
it would be great to see a test for this, but it is just a minor change.
Comment 6 Darin Adler 2011-01-19 18:18:30 PST
Comment on attachment 78326 [details]
Patch

Clearing flags on attachment: 78326

Committed r76191: <http://trac.webkit.org/changeset/76191>
Comment 7 Darin Adler 2011-01-19 18:18:35 PST
All reviewed patches have been landed.  Closing bug.
Comment 8 WebKit Review Bot 2011-01-19 19:14:30 PST
http://trac.webkit.org/changeset/76191 might have broken SnowLeopard Intel Release (Tests)
The following tests are not passing:
fast/forms/input-text-scroll-left-on-blur.html