Naming a member variable "view" is not correct according to the WebKit style guidelines. Furthermore makes it difficult to distinguish such a member from an argument named "view".
Created attachment 78176 [details]
Comment on attachment 78176 [details]
View in context: https://bugs.webkit.org/attachment.cgi?id=78176&action=review
The general rule is that public member variables don't have an "m_" prefix.
You could make them private and add setters/getters as needed.
> - : view(newView)
> - , page(newPage)
> + : m_view(newView)
> + , m_page(newPage)
> #if USE(ACCELERATED_COMPOSITING) && USE(TEXTURE_MAPPER)
> , syncTimer(this, &PageClientQWidget::syncLayers)
> , platformLayerProxy(0)
Looks like you missed 'syncTimer' and 'platformLayerProxy'.