Bug 51806 - "Tool/Scripts/run-launcher --gtk" stopped working after 74855
Summary: "Tool/Scripts/run-launcher --gtk" stopped working after 74855
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC All
: P2 Trivial
Assignee: Nobody
URL:
Keywords:
: 51816 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-01-02 19:40 PST by Koan-Sin Tan
Modified: 2011-01-03 06:00 PST (History)
4 users (show)

See Also:


Attachments
proposed patch (1.13 KB, patch)
2011-01-02 20:51 PST, Koan-Sin Tan
xan.lopez: review-
xan.lopez: commit-queue-
Details | Formatted Diff | Diff
proposed patch (1.52 KB, patch)
2011-01-03 05:25 PST, Koan-Sin Tan
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Koan-Sin Tan 2011-01-02 19:40:18 PST
"Tool/Scripts/run-launcher --gtk" stopped working after 74855 (JavaScriptCore/ moved to Source/JavaScriptCore)

should fix Tools/Scripts/webkitdirs.pm
Comment 1 Koan-Sin Tan 2011-01-02 20:51:03 PST
Created attachment 77790 [details]
proposed patch

this is kinda trivial
Comment 2 Xan Lopez 2011-01-03 04:23:05 PST
(In reply to comment #1)
> Created an attachment (id=77790) [details]
> proposed patch
> 
> this is kinda trivial

I must admit I don't get what the patch is supposed to achieve or how it's related to moving JSC to Source/. Can you explain?
Comment 3 Xan Lopez 2011-01-03 04:32:45 PST
(In reply to comment #2)
> (In reply to comment #1)
> > Created an attachment (id=77790) [details] [details]
> > proposed patch
> > 
> > this is kinda trivial
> 
> I must admit I don't get what the patch is supposed to achieve or how it's related to moving JSC to Source/. Can you explain?

From talking to Philippe (who also sees the brokeness), it seems that the problem is that this is called with JavaScriptCore as $libraryName, which does not exist now as a directory, so the whole thing will fail. I'm not sure what was the point of doing $dir/$foo/../.libs, but I think just $dir/.libs is OK as you suggest. I wonder if this has changed recently, our solution (and Qt, Elf,...) does not seem so robust anymore.
Comment 4 Xan Lopez 2011-01-03 04:33:21 PST
Comment on attachment 77790 [details]
proposed patch

The patch is good, but you need to explain a bit more what's going on in the ChangeLog. Thanks!
Comment 5 Philippe Normand 2011-01-03 04:51:01 PST
it used to work before JavascriptCore moved to Source/:

/path/to/WebKitBuild/JavascriptCore/../.libs existed

but now indeed:

/path/to/WebkitBuild/Source/JavascriptCore/../.libs doesn't exist.

Using ../../.libs would work but I agree with Xan that the proposed patch is better
Comment 6 Koan-Sin Tan 2011-01-03 04:56:14 PST
(In reply to comment #5)
> it used to work before JavascriptCore moved to Source/:
> 
> /path/to/WebKitBuild/JavascriptCore/../.libs existed
> 
> but now indeed:
> 
> /path/to/WebkitBuild/Source/JavascriptCore/../.libs doesn't exist.
> 
> Using ../../.libs would work but I agree with Xan that the proposed patch is better

yeah, I don't know why that was "JavascriptCore/../" which doesn't really make sense to me, so i removed it
Comment 7 Xan Lopez 2011-01-03 05:19:11 PST
*** Bug 51816 has been marked as a duplicate of this bug. ***
Comment 8 Koan-Sin Tan 2011-01-03 05:25:25 PST
Created attachment 77804 [details]
proposed patch

add some explanation as Xan suggested
Comment 9 Xan Lopez 2011-01-03 05:27:12 PST
Comment on attachment 77804 [details]
proposed patch

Thank you!
Comment 10 WebKit Commit Bot 2011-01-03 05:59:33 PST
The commit-queue encountered the following flaky tests while processing attachment 77804 [details]:

http/tests/xmlhttprequest/access-control-preflight-credential-async.html bug 51817 (author: jchaffraix@webkit.org)
The commit-queue is continuing to process your patch.
Comment 11 WebKit Commit Bot 2011-01-03 06:00:34 PST
Comment on attachment 77804 [details]
proposed patch

Clearing flags on attachment: 77804

Committed r74889: <http://trac.webkit.org/changeset/74889>
Comment 12 WebKit Commit Bot 2011-01-03 06:00:41 PST
All reviewed patches have been landed.  Closing bug.