Bug 51630 - Move autotools into Sources
Summary: Move autotools into Sources
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other OS X 10.5
: P2 Normal
Assignee: Adam Barth
URL:
Keywords:
Depends on:
Blocks: 51606
  Show dependency treegraph
 
Reported: 2010-12-26 22:27 PST by Adam Barth
Modified: 2010-12-26 23:26 PST (History)
5 users (show)

See Also:


Attachments
Patch (27.13 KB, patch)
2010-12-26 22:29 PST, Adam Barth
eric: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Barth 2010-12-26 22:27:20 PST
Move autotools into Tools
Comment 1 Adam Barth 2010-12-26 22:29:03 PST
Created attachment 77478 [details]
Patch
Comment 2 Adam Barth 2010-12-26 22:29:43 PST
I don't fully understand how autotools works, so this patch is more of a guess.
Comment 3 Eric Seidel (no email) 2010-12-26 22:34:02 PST
Comment on attachment 77478 [details]
Patch

I guess I would have put such in some sort of build directory, but this is fine. :)
Comment 4 WebKit Review Bot 2010-12-26 22:34:15 PST
Attachment 77478 [details] did not build on gtk:
Build output: http://queues.webkit.org/results/7342020
Comment 5 Adam Barth 2010-12-26 22:35:22 PST
I was wondering about putting it in the Sources folder b/c that's where things like the XCode projects will be.  The cmake folder is another example of this sort of thing.
Comment 6 Adam Barth 2010-12-26 22:50:03 PST
Chatting on IRC, Eric and I thought that Sources might be better because this stuff is more like the Xcode project than like build-webkit (which is really just a wrapper script).
Comment 7 Adam Barth 2010-12-26 23:26:09 PST
I tried landing this change in http://trac.webkit.org/changeset/74677.  Hopefully the bots will complain if I screwed it up.