I just changed the spec to say that % values in the z-component of translate3d(), translateZ() and transform-origin should make the property invalid. We should implement this.
This already works for -webkit-transform-origin.
Created attachment 76631 [details]
Attachment 76631 [details] did not pass style-queue:
Failed to run "['WebKitTools/Scripts/check-webkit-style', '--diff-files', u'LayoutTests/ChangeLog', u'LayoutTests/transforms/2d/resources/transform-test-utils.js', u'LayoutTests/transforms/3d/general/3dtransform-values-expected.txt', u'LayoutTests/transforms/3d/general/3dtransform-values.html', u'WebCore/ChangeLog', u'WebCore/css/CSSParser.cpp']" exit_code: 1
WebCore/css/CSSParser.cpp:5006: Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons. [readability/comparison_to_zero] 
Total errors found: 1 in 6 files
If any of these errors are false positives, please file a bug against check-webkit-style.
Comment on attachment 76631 [details]
r+ with the comment change to get rid of transform-origin wording. You should also fix the style issue, unless it's just noise from the style bot