Bug 50654 - REGRESSION: Invalid regular expression errors on this site
Summary: REGRESSION: Invalid regular expression errors on this site
Status: RESOLVED DUPLICATE of bug 50483
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Gavin Barraclough
URL: http://ecsstender.org/demos/spoon/
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2010-12-07 16:26 PST by Simon Fraser (smfr)
Modified: 2010-12-08 21:52 PST (History)
5 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Fraser (smfr) 2010-12-07 16:26:11 PST
Hovering over "Spooon" on this site no longer does transitions.

It looks like the page is trying to do feature detection, and is serving up un-prefixed 'transform' properties now. I'm not sure why.
Comment 1 Simon Fraser (smfr) 2010-12-07 17:01:55 PST
The real issue is:
SyntaxError: Invalid regular expression: invalid range in character class:

Beautifying the source, I see failures relating to the following lines:

        bO = bO.replace(/#[\w-_]+/, aA);

        bO = bO.replace(/(?:::|:|\.)[\w-_()]+|\[.*?\]/, aA);
Comment 2 Simon Fraser (smfr) 2010-12-07 17:02:37 PST
<rdar://problem/8741502>
Comment 3 Gavin Barraclough 2010-12-08 12:55:56 PST
The problem here is that /[\w-_]/ is technically invalid, and we've been experimenting with slightly closer conformance to the spec in our regex engine.  This appears to be breaking the web, so we'll be relaxing our interpretation of these rules again soon.

cheers,
G.
Comment 4 Gavin Barraclough 2010-12-08 21:52:08 PST
This should be fixed in r73594.

*** This bug has been marked as a duplicate of bug 50483 ***