Bug 50638 - Web Inspector: warning icon for unrecognized style rule should have tooltip
: Web Inspector: warning icon for unrecognized style rule should have tooltip
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated)
: 528+ (Nightly build)
: All All
: P2 Normal
Assigned To: Alexander Pavlov (apavlov)
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-07 11:19 PST by Joseph Pecoraro
Modified: 2011-11-23 06:34 PST (History)
9 users (show)

See Also:


Attachments
Patch (4.68 KB, patch)
2011-11-23 06:19 PST, Alexander Pavlov (apavlov)
yurys: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph Pecoraro 2010-12-07 11:19:20 PST
When a CSS style rule is "not parsed okay" it has a warning icon. However, the reason
that warning icon is there is not known. There should be a tooltip, or something else,
with the image to explain to user why the warning is there. There could be a number
of reasons:

  - unknown property (-moz-something: ...)
  - unknown value for property (color: a)
  - other?

Currently the image is inserted via CSS if the property was (!parsedOk). The
CSS in inspector.css is:

>  .styles-section .properties li.not-parsed-ok::before {
>      content: url(Images/warningIcon.png);
>      ...
>  }
Comment 1 Joseph Pecoraro 2010-12-07 11:20:35 PST
Another issue might just a syntax issue. That is probably indistinguishable between an
unknown value for property.
Comment 2 Alexander Pavlov (apavlov) 2011-05-07 01:52:38 PDT
*** Bug 60431 has been marked as a duplicate of this bug. ***
Comment 3 Alexander Pavlov (apavlov) 2011-11-23 06:19:35 PST
Created attachment 116350 [details]
Patch
Comment 4 Alexander Pavlov (apavlov) 2011-11-23 06:34:27 PST
Committed r101080: <http://trac.webkit.org/changeset/101080>