Bug 50561 - [gtk] Make PAN_SCROLLING a runtime setting and not a build time flag
Summary: [gtk] Make PAN_SCROLLING a runtime setting and not a build time flag
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Gtk (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks: 84693
  Show dependency treegraph
 
Reported: 2010-12-06 04:40 PST by Diego Escalante Urrelo
Modified: 2015-05-07 17:19 PDT (History)
8 users (show)

See Also:


Attachments
First go, doesn't have a changelog, I know. (16.23 KB, patch)
2010-12-06 04:42 PST, Diego Escalante Urrelo
no flags Details | Formatted Diff | Diff
Make pan scrolling a setting and not a build flag #2 (15.87 KB, patch)
2011-02-03 09:09 PST, Christian Dywan
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Escalante Urrelo 2010-12-06 04:40:44 PST
ssia.

Attaching a patch that:
 - makes it a runtime setting
 - updates the Qt port (which was relying on the flag)
 - adds a wrapper for the setting in the GTK+ port

Yes, I know it doesn't have a changelog, it would take me a few more days to update my webkit :)
Comment 1 Diego Escalante Urrelo 2010-12-06 04:42:04 PST
Created attachment 75674 [details]
First go, doesn't have a changelog, I know.
Comment 2 Christian Dywan 2011-02-03 09:09:31 PST
Created attachment 81068 [details]
Make pan scrolling a setting and not a build flag #2

Updated patch to build with current TOT. I also added an explanation what the feature does because it is impossible to find in a web search. Finding a more descriptive name would be nice, but I don't really know.
Comment 3 Christian Dywan 2011-02-03 09:13:47 PST
One thing I wondered after preparing the patch: is it also an option to unconditionally enable this or are there known drawbacks? It's overall not that complex so it doesn't really impact build time or size.
Comment 4 Christian Dywan 2011-02-08 07:00:32 PST
David, what do you think?
Comment 5 Ben Stern 2011-02-25 12:37:27 PST
In the UNIX Firefox world, middle clicking in a web page (if not on a link) pastes the X copy buffer.  This is inherited from old Netscape behavior.  I think that this is probably the expected behavior for UNIX users.

As far as I recall, middle-clicking in IE and Firefox under Windows triggers Pan Scrolling.  To Windows users, this is probably the expected behavior.

I do not know how to reconcile this difference in UI between platforms, but I thought I should add the additional information/
Comment 6 Philippe Normand 2012-04-24 03:07:31 PDT
If you ever want a review of this patch you might want to mark it r?. :)
Comment 7 Martin Robinson 2015-05-07 17:19:36 PDT
I don't think this is something we want for WebKitGTK+ ATM.