Bug 50436 - REGRESSION(r69429-r69611): Amazon.com Gold Box Lightning Deals do not render on Leopard
: REGRESSION(r69429-r69611): Amazon.com Gold Box Lightning Deals do not render ...
Status: RESOLVED DUPLICATE of bug 48377
: WebKit
New Bugs
: 528+ (Nightly build)
: Macintosh Mac OS X 10.5
: P1 Normal
Assigned To:
: http://www.amazon.com/gp/goldbox/ref=...
: InRadar, NeedsReduction, Regression
:
:
  Show dependency treegraph
 
Reported: 2010-12-02 21:07 PST by
Modified: 2010-12-06 14:53 PST (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2010-12-02 21:07:04 PST
I was using the latest Webkit Nightly when I noticed that Amazon.com's Gold Box Lightning Deals weren't rendering at all. This is on Leopard using a PowerPC G5. The error console displays the following:

ReferenceError: Strict mode forbids implicit creation of global property 'Deal'

which may indicate a JavaScript bug.

According to smfr on #webkit IRC, the Lightning Deals box renders on Snow Leopard using a recent build, so this problem may be Leopard-only or even PowerPC-only.

Using the Webkit Nightly builds, I've narrowed down the regression to be between r69429 (which renders correctly) and r69611 (which renders incorrectly). Perhaps someone can use git-bisect or whatever to further narrow down the regression to a specific revision.
------- Comment #1 From 2010-12-02 21:10:35 PST -------
<rdar://problem/8724844>
------- Comment #2 From 2010-12-06 14:53:41 PST -------

*** This bug has been marked as a duplicate of bug 48377 ***