Bug 50320 - REGRESSION (r72813): Confluence script boxes do not render content
Summary: REGRESSION (r72813): Confluence script boxes do not render content
Status: RESOLVED DUPLICATE of bug 50483
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P1 Normal
Assignee: Nobody
URL: http://confluence.atlassian.com/displ...
Keywords: InRadar, Regression
Depends on: 48100
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-01 06:13 PST by Dimitris Apostolou
Modified: 2011-01-04 20:03 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dimitris Apostolou 2010-12-01 06:13:45 PST
r72896

Reproducibility: always

Steps:
1. Create a free Confluence account in http://confluence.atlassian.com
2. Go to http://confluence.atlassian.com/display/TST/Test+WebKit+regression that I have created to demonstrate the regression.

What happened:
2. The content inside the box is not rendered.

I used the following WiKi markup code:

{newcode}
$ some command here
{newcode}

When inspected it is:

<div class="codeContent panelContent">
  <script type="syntaxhighlighter" class="toolbar: false; theme: Confluence; brush: java; gutter: false"><![CDATA[
  $ some command here
  ]]></script>
</div>

Expected result:
2. The content inside the box is rendered.
Comment 1 Dimitris Apostolou 2010-12-01 06:38:33 PST
Regression was introduced with r72896
Comment 2 Alexey Proskuryakov 2010-12-01 13:09:12 PST
<rdar://problem/8717440>
Comment 3 Andy Estes 2011-01-04 19:55:12 PST
The regression was introduced by http://trac.webkit.org/changeset/72813, but was later fixed by http://trac.webkit.org/changeset/73594. Dimitris, can you verify this in a WebKit nightly build later than r73594?
Comment 4 Andy Estes 2011-01-04 20:03:44 PST
Looks like the other regressions from r72813 were marked as a duplicate of https://bugs.webkit.org/show_bug.cgi?id=50483.

*** This bug has been marked as a duplicate of bug 50483 ***