Bug 50186 - Switch web audio code to use FloatPoint3D instead of Vector3
Summary: Switch web audio code to use FloatPoint3D instead of Vector3
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-29 14:29 PST by Chris Rogers
Modified: 2010-11-29 18:03 PST (History)
4 users (show)

See Also:


Attachments
Patch (14.31 KB, patch)
2010-11-29 14:34 PST, Chris Rogers
no flags Details | Formatted Diff | Diff
Patch (19.12 KB, patch)
2010-11-29 16:13 PST, Chris Rogers
kbr: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Rogers 2010-11-29 14:29:19 PST
Switch web audio code to use FloatPoint3D instead of Vector3
Comment 1 Chris Rogers 2010-11-29 14:34:15 PST
Created attachment 75063 [details]
Patch
Comment 2 Kenneth Russell 2010-11-29 14:54:26 PST
Comment on attachment 75063 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=75063&action=review

Are these the last uses of Vector3? If so, I think we should remove those files as well. Or is that planned in a separate patch?

> WebCore/platform/graphics/FloatPoint3D.h:178
> +inline double distance(const FloatPoint3D& a, const FloatPoint3D& b)

I'm not sure that adding this function to the global WebCore namespace is a good idea. Could it be expressed as a method "double distanceTo(const FloatPoint3D& other) const"?
Comment 3 Chris Rogers 2010-11-29 16:13:14 PST
Created attachment 75077 [details]
Patch
Comment 4 Chris Rogers 2010-11-29 16:15:21 PST
> Are these the last uses of Vector3? If so, I think we should remove those files as well. Or is that planned in a separate patch?

Yes, the new patch also removes wtf/Vector3.h



>> WebCore/platform/graphics/FloatPoint3D.h:178
>> +inline double distance(const FloatPoint3D& a, const FloatPoint3D& b)

> I'm not sure that adding this function to the global WebCore namespace is a good idea. Could it be expressed as a method "double distanceTo(const FloatPoint3D& other) const"?

Yes, I've changed this method to distanceTo() as you propose.
Comment 5 Kenneth Russell 2010-11-29 17:04:22 PST
Comment on attachment 75077 [details]
Patch

Looks good to me.
Comment 6 Chris Rogers 2010-11-29 17:19:01 PST
Committed r72853: <http://trac.webkit.org/changeset/72853>
Comment 7 WebKit Review Bot 2010-11-29 18:03:38 PST
http://trac.webkit.org/changeset/72853 might have broken SnowLeopard Intel Release (Tests)
The following tests are not passing:
fast/profiler/throw-exception-from-eval.html