Bug 50185 - Should be able to pause and resume downloads
Summary: Should be able to pause and resume downloads
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other OS X 10.5
: P2 Normal
Assignee: Anders Carlsson
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2010-11-29 14:23 PST by Anders Carlsson
Modified: 2010-11-29 15:34 PST (History)
1 user (show)

See Also:


Attachments
Patch (19.03 KB, patch)
2010-11-29 14:30 PST, Anders Carlsson
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Anders Carlsson 2010-11-29 14:23:43 PST
Should be able to pause and resume downloads
Comment 1 Anders Carlsson 2010-11-29 14:24:04 PST
<rdar://problem/8691135>
Comment 2 Anders Carlsson 2010-11-29 14:30:45 PST
Created attachment 75062 [details]
Patch
Comment 3 Darin Adler 2010-11-29 14:37:13 PST
Comment on attachment 75062 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=75062&action=review

Might be better to name this resumptionData rather than resumeData so it doesn’t sound like a verb phrase. But I guess the NSURLDownload method is already named resumeData?

> WebKit2/UIProcess/Downloads/DownloadProxy.cpp:153
> +    if (!resumeData.isEmpty())
> +        m_resumeData = WebData::create(resumeData.data(), resumeData.size());

Would be nice to share this code instead of writing it twice.
Comment 4 Anders Carlsson 2010-11-29 14:41:04 PST
(In reply to comment #3)
> (From update of attachment 75062 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=75062&action=review
> 
> Might be better to name this resumptionData rather than resumeData so it doesn’t sound like a verb phrase. But I guess the NSURLDownload method is already named resumeData?

Yeah.

> 
> > WebKit2/UIProcess/Downloads/DownloadProxy.cpp:153
> > +    if (!resumeData.isEmpty())
> > +        m_resumeData = WebData::create(resumeData.data(), resumeData.size());
> 
> Would be nice to share this code instead of writing it twice.

Fixed.

Thanks for reviewing!
Comment 5 Anders Carlsson 2010-11-29 15:34:55 PST
Committed r72841: <http://trac.webkit.org/changeset/72841>