Bug 49913 - CSS box shadow with percent radius should compute radius based on shadow's own width
Summary: CSS box shadow with percent radius should compute radius based on shadow's ow...
Status: RESOLVED DUPLICATE of bug 49726
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Renata Hodovan
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-22 09:06 PST by Andreas Kling
Modified: 2011-01-19 23:23 PST (History)
2 users (show)

See Also:


Attachments
Simple page illustrating the problem (661 bytes, text/html)
2010-11-22 09:07 PST, Andreas Kling
no flags Details
WebKit's rendering of test page (12.75 KB, image/png)
2010-11-22 09:08 PST, Andreas Kling
no flags Details
Firefox4's rendering of test page (20.18 KB, image/png)
2010-11-22 09:08 PST, Andreas Kling
no flags Details
repro with px. (1006 bytes, text/html)
2010-12-23 21:49 PST, Hajime Morrita
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Kling 2010-11-22 09:06:55 PST
A cursory glance points at RenderBoxModelObject::paintBoxShadow() which uses the values from RenderStyle::getBorderRadiiForRect() for the shadow as well. If the border-radius is specified in percent, those values should be relative to the shadow's size (with spread taken into account), not the element casting the shadow.

Screenshots from WebKit and Firefox4 coming..
Comment 1 Andreas Kling 2010-11-22 09:07:47 PST
Created attachment 74559 [details]
Simple page illustrating the problem
Comment 2 Andreas Kling 2010-11-22 09:08:20 PST
Created attachment 74560 [details]
WebKit's rendering of test page
Comment 3 Andreas Kling 2010-11-22 09:08:59 PST
Created attachment 74561 [details]
Firefox4's rendering of test page
Comment 4 Hajime Morrita 2010-12-23 21:49:08 PST
Created attachment 77400 [details]
repro with px.

This isn't limited for percentage value. other values are should be also scaled accordingly
because box-radius is for "box", not shadow. 
Mozilla and Opera do scale.
Comment 5 Hajime Morrita 2010-12-23 22:15:45 PST
Ah, I realized that this is a dup of Bug 49726

*** This bug has been marked as a duplicate of bug 49726 ***
Comment 6 Hajime Morrita 2011-01-19 23:23:32 PST
Bug 27417 and LayoutTests/fast/box-shadow/spread.html says this is intentional.
But I don't think so.

Any opinions?