Bug 49869 - ASSERTION FAILED: !protectedObjectCount() running fast/workers/storage/use-same-database-in-page-and-workers.html
Summary: ASSERTION FAILED: !protectedObjectCount() running fast/workers/storage/use-sa...
Status: RESOLVED DUPLICATE of bug 59801
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Mac OS X 10.6
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2010-11-20 13:30 PST by David Kilzer (:ddkilzer)
Modified: 2012-01-10 02:05 PST (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Kilzer (:ddkilzer) 2010-11-20 13:30:49 PST
* SUMMARY
Assertion failure running fast/workers/storage/use-same-database-in-page-and-workers.html.

* STEPS TO REPRODUCE
1. $ ./WebKitTools/Scripts/build-webkit --debug
2. $ ./WebKitTools/Scripts/run-webkit-tests --debug --iterations 100 fast/workers/storage

* RESULTS
LayoutTests/fast/workers/storage/use-same-database-in-page-and-workers.html crashes the second time it's run.  It failed the first time.

Running tests from /Volumes/Data/WebKit.git/LayoutTests
Testing 26 test cases 100 times.
fast/workers/storage ..........................
fast/workers/storage/use-same-database-in-page-and-workers.html -> failed
..........................
fast/workers/storage/use-same-database-in-page-and-workers.html -> crashed
..........................
fast/workers/storage/use-same-database-in-page-and-workers.html -> crashed
....................................................
fast/workers/storage/use-same-database-in-page-and-workers.html -> crashed
..........................
fast/workers/storage/use-same-database-in-page-and-workers.html -> crashed
..............................................................................
fast/workers/storage/use-same-database-in-page-and-workers.html -> crashed
..................................................^C
Comment 1 David Kilzer (:ddkilzer) 2010-11-20 13:31:23 PST
See also Bug 48457.
Comment 2 David Kilzer (:ddkilzer) 2010-11-20 13:31:45 PST
<rdar://problem/8692065>
Comment 3 Ryosuke Niwa 2012-01-10 02:05:32 PST

*** This bug has been marked as a duplicate of bug 59801 ***