Bug 49728 - REGRESSION(r72288): Did not build on Win. Rolling out. (Requested by krit on #webkit).
Summary: REGRESSION(r72288): Did not build on Win. Rolling out. (Requested by krit on ...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other OS X 10.5
: P2 Normal
Assignee: WebKit Review Bot
URL:
Keywords:
Depends on:
Blocks: 49580
  Show dependency treegraph
 
Reported: 2010-11-18 06:26 PST by WebKit Review Bot
Modified: 2015-10-01 16:22 PDT (History)
4 users (show)

See Also:


Attachments
ROLLOUT of r72288 (1012.61 KB, patch)
2010-11-18 06:26 PST, WebKit Review Bot
no flags Details | Formatted Diff | Diff
Patch (1.11 KB, patch)
2015-10-01 15:36 PDT, Ryan Haddad
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description WebKit Review Bot 2010-11-18 06:26:08 PST
http://trac.webkit.org/changeset/72288 broke the build:
Did not build on Win. Rolling out. (Requested by krit on #webkit).

This is an automatic bug report generated by the sheriff-bot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests case pain.

"Only you can prevent forest fires." -- Smokey the Bear
Comment 1 WebKit Review Bot 2010-11-18 06:26:35 PST
Created attachment 74232 [details]
ROLLOUT of r72288

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the rollout will be successful.  This process takes approximately 15 minutes.

If you would like to land the rollout faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID --ignore-builders

where ATTACHMENT_ID is the ID of this attachment.
Comment 2 WebKit Commit Bot 2010-11-18 08:03:01 PST
Comment on attachment 74232 [details]
ROLLOUT of r72288

Rejecting patch 74232 from commit-queue.

Failed to run "['./WebKitTools/Scripts/webkit-patch', '--status-host=queues.webkit.org', '--bot-id=eseidel-cq-sl', 'build', '--no-clean', '--no-update', '--build-style=both']" exit_code: 2
Last 500 characters of output:
Objects-normal/x86_64/HTMLScriptRunner.o /Projects/CommitQueue/WebCore/html/parser/HTMLScriptRunner.cpp normal x86_64 c++ com.apple.compilers.gcc.4_2
	CompileC /Projects/CommitQueue/WebKitBuild/WebCore.build/Debug/WebCore.build/Objects-normal/x86_64/HTMLTextAreaElement.o /Projects/CommitQueue/WebCore/html/HTMLTextAreaElement.cpp normal x86_64 c++ com.apple.compilers.gcc.4_2
(4 failures)

Use of uninitialized value $_[0] in join or string at /System/Library/Perl/5.10.0/File/Spec/Unix.pm line 81.

Full output: http://queues.webkit.org/results/6264016
Comment 3 Nikolas Zimmermann 2010-11-19 05:22:00 PST
Already got rolled out and relanded.
Comment 4 Ryan Haddad 2015-10-01 15:36:51 PDT
Reopening to attach new patch.
Comment 5 Ryan Haddad 2015-10-01 15:36:53 PDT
Created attachment 262289 [details]
Patch
Comment 6 Ryan Haddad 2015-10-01 15:38:47 PDT
Accidentally reopened due to typo in bug number. Marking as resolved.