Bug 4948 - Incorrect HTML entity error recovery doesn't match other browsers
: Incorrect HTML entity error recovery doesn't match other browsers
Status: RESOLVED FIXED
Product: WebKit
Classification: Unclassified
Component: HTML DOM
: 420+
: Macintosh Mac OS X 10.4
: P3 Enhancement
Assigned To: Nobody
: HasReduction, InRadar
Depends on: 6446 32377
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-12 01:41 PDT by Alexey Proskuryakov
Modified: 2014-11-10 12:52 PST (History)
5 users (show)

See Also:


Attachments
test matrix (3.54 KB, text/html)
2005-09-12 01:42 PDT, Alexey Proskuryakov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2005-09-12 01:41:57 PDT
(from discussion in bug 4820)

Attached is a test matrix for invalid HTML entities with results for several browsers. Apparently, different 
browsers have little in common here, yet Safari matches none of them.

Perhaps, this should be improved.
Comment 1 Alexey Proskuryakov 2005-09-12 01:42:23 PDT
Created attachment 3875 [details]
test matrix
Comment 2 Eric Seidel 2005-12-28 01:35:59 PST
What a great table.  The code for all this is inside htmltokenizer.cpp.
Comment 3 Alexey Proskuryakov 2008-03-28 02:17:32 PDT
Bug 17689 has an example of this.
Comment 4 Alexey Proskuryakov 2008-03-28 02:17:57 PDT
<rdar://problem/5827553>
Comment 5 Sam Weinig 2008-07-28 17:52:38 PDT
This logic should be covered by http://www.whatwg.org/specs/web-apps/current-work/multipage/tokenization.html#consume 
Comment 6 Adam Barth 2010-11-01 22:21:53 PDT
Our goal here is to match the HTML5 spec.  How does a WebKit nightly compare to Firefox 4 beta?
Comment 7 Adam Barth 2010-11-01 22:24:18 PDT
Looks like we match Firefox 4 on everything except:

&#4294967393;
&#18446744073709551713;
&#79228162514264337593543950433;
&#x100000061;
Comment 8 David Kilzer (:ddkilzer) 2014-11-10 12:52:08 PST
(In reply to comment #7)
> Looks like we match Firefox 4 on everything except:
> 
> &#4294967393;
> &#18446744073709551713;
> &#79228162514264337593543950433;
> &#x100000061;

The above test cases match "Firefox (Mac)" column, and WebKit matches Firefox 33.1 except for these four cases (which look like regressions in Firefox per the chart):

&#4294967393; (0x100000061)
&#18446744073709551713;
&#79228162514264337593543950433;
&#x100000061;

Marking as RESOLVED/FIXED.