Bug 49224 - [Chromium] Text jitter during 2D CSS transform
Summary: [Chromium] Text jitter during 2D CSS transform
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-08 16:47 PST by Mihai Parparita
Modified: 2010-11-09 21:25 PST (History)
5 users (show)

See Also:


Attachments
Test case (1.56 KB, text/html)
2010-11-08 16:47 PST, Mihai Parparita
no flags Details
Patch (5.26 KB, patch)
2010-11-09 14:56 PST, Nico Weber
no flags Details | Formatted Diff | Diff
Patch (5.76 KB, patch)
2010-11-09 15:08 PST, Nico Weber
no flags Details | Formatted Diff | Diff
Patch (5.76 KB, patch)
2010-11-09 15:54 PST, Nico Weber
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mihai Parparita 2010-11-08 16:47:36 PST
Created attachment 73307 [details]
Test case

With Chrome 9.0.572.0 on Snow Leopard, the attached test case (which triggers a 2D rotation on hover) exhibits text jitter during the transition. WebKit nightlies do not.

I showed this to James, he wasn't sure if WebKit/Mac also uses the compositor but is better about text rendering, or if they're not ending up on their compositor code path in the first place.
Comment 1 Nico Weber 2010-11-08 16:51:37 PST
I bet this is a dupe of http://crbug.com/61647 . Looks like we just don't tell the context that it's ok to do subpixel aa.
Comment 2 Mihai Parparita 2010-11-08 16:52:35 PST
This may be related to http://crbug.com/57645, which was recently fixed. Is that change in the current dev channel? The last comments claims that it is, but http://nettuts.s3.amazonaws.com/771_sticky/step5.html still has (similar) flicker during transitions.
Comment 3 Nico Weber 2010-11-08 17:01:12 PST
http://crbug.com/57645 is fixed, the fix is on the dev channel, and it's unrelated. See comment 1.
Comment 4 Nico Weber 2010-11-09 14:56:48 PST
Created attachment 73426 [details]
Patch
Comment 6 Kenneth Russell 2010-11-09 15:06:45 PST
Comment on attachment 73426 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=73426&action=review

> WebCore/platform/graphics/chromium/ContentLayerChromium.cpp:-88
> -#if PLATFORM(SKIA)
>          "  gl_FragColor = vec4(texColor.z, texColor.y, texColor.x, texColor.w) * alpha; \n"
> -#elif PLATFORM(CG)
> -        "  gl_FragColor = vec4(texColor.x, texColor.y, texColor.z, texColor.w) * alpha; \n"
> -#else
> -#error "Need to implement for your platform."
> -#endif

Could you also update the comment at the top of this block (not in this review)?
Comment 7 Nico Weber 2010-11-09 15:08:48 PST
Created attachment 73429 [details]
Patch
Comment 8 Kenneth Russell 2010-11-09 15:16:12 PST
Comment on attachment 73429 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=73429&action=review

Looks fine. One minor typo in comment; can fix upon commit.

> WebCore/platform/graphics/chromium/ContentLayerChromium.cpp:71
> +    // Color is in uses BGRA order.

Typo: "in uses BGRA" -> "in BGRA"
Comment 9 Nico Weber 2010-11-09 15:54:31 PST
Created attachment 73432 [details]
Patch
Comment 10 WebKit Commit Bot 2010-11-09 21:25:14 PST
Comment on attachment 73432 [details]
Patch

Clearing flags on attachment: 73432

Committed r71717: <http://trac.webkit.org/changeset/71717>
Comment 11 WebKit Commit Bot 2010-11-09 21:25:19 PST
All reviewed patches have been landed.  Closing bug.