Bug 49217 - REGRESSION: Two layout tests failing after positionForPoint changes.
Summary: REGRESSION: Two layout tests failing after positionForPoint changes.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P1 Normal
Assignee: Dave Hyatt
URL:
Keywords:
Depends on: 49243
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-08 15:54 PST by Dave Hyatt
Modified: 2010-12-14 01:43 PST (History)
4 users (show)

See Also:


Attachments
Patch (4.43 KB, patch)
2010-11-08 15:57 PST, Dave Hyatt
simon.fraser: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Hyatt 2010-11-08 15:54:31 PST
Two layout tests failing after positionForPoint changes.
Comment 1 Dave Hyatt 2010-11-08 15:57:03 PST
Created attachment 73300 [details]
Patch
Comment 2 Dave Hyatt 2010-11-08 16:00:06 PST
Fixed in r71582.
Comment 3 WebKit Review Bot 2010-11-08 16:20:45 PST
http://trac.webkit.org/changeset/71582 might have broken Qt Linux Release
Comment 4 Csaba Osztrogonác 2010-11-09 00:43:20 PST
(In reply to comment #3)
> http://trac.webkit.org/changeset/71582 might have broken Qt Linux Release

It fixed the two broken tests: editing/selection/move-by-line-003.html and 
fast/dom/Document/CaretRangeFromPoint/replace-element.html on all bot, but
unfortunately it broke two another tests on Qt bot:
- editing/deleting/delete-line-011.html
- editing/pasteboard/paste-4039777-fix.html
- link: http://build.webkit.org/results/Qt%20Linux%20Release/r71582%20%2823376%29/results.html
Comment 5 Csaba Osztrogonác 2010-11-09 02:14:06 PST
New bug filed for new regression: https://bugs.webkit.org/show_bug.cgi?id=49243
Comment 6 Eric Seidel (no email) 2010-12-14 01:43:57 PST
Looks like this was fixed?