Bug 49150 - [GTK] LayoutTests/fast/events/spatial-navigation/snav-single-select.html fails on GTK
Summary: [GTK] LayoutTests/fast/events/spatial-navigation/snav-single-select.html fail...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Chang Shu
URL:
Keywords:
: 49176 (view as bug list)
Depends on:
Blocks: 47094
  Show dependency treegraph
 
Reported: 2010-11-07 17:53 PST by Chang Shu
Modified: 2010-11-08 21:24 PST (History)
3 users (show)

See Also:


Attachments
fix patch (2.15 KB, patch)
2010-11-08 11:53 PST, Chang Shu
no flags Details | Formatted Diff | Diff
fix patch 2 (3.26 KB, patch)
2010-11-08 12:32 PST, Chang Shu
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chang Shu 2010-11-07 17:53:22 PST
The above test works on Qt but fails on GTK. It also hangs on Mac but skipped. Most likely it's because of the different implementations of select box on different platforms.
Comment 1 Chang Shu 2010-11-08 07:38:12 PST
*** Bug 49176 has been marked as a duplicate of this bug. ***
Comment 2 Antonio Gomes 2010-11-08 07:39:44 PST
If a solution is not coming shortly, please skip it and unskip with the real patch.
Comment 3 Chang Shu 2010-11-08 07:42:39 PST
(In reply to comment #2)
> If a solution is not coming shortly, please skip it and unskip with the real patch.

sure, I will see if I can get it done by end of today.
Comment 4 Chang Shu 2010-11-08 11:53:26 PST
Created attachment 73259 [details]
fix patch

This could fix Mac, too. I will update the patch if this is the case.
Comment 5 Antonio Gomes 2010-11-08 12:04:27 PST
It looks nice. Could you please unskip the test in GTK+?
Comment 6 Chang Shu 2010-11-08 12:32:55 PST
Created attachment 73267 [details]
fix patch 2
Comment 7 WebKit Commit Bot 2010-11-08 21:24:13 PST
Comment on attachment 73267 [details]
fix patch 2

Clearing flags on attachment: 73267

Committed r71605: <http://trac.webkit.org/changeset/71605>
Comment 8 WebKit Commit Bot 2010-11-08 21:24:19 PST
All reviewed patches have been landed.  Closing bug.