Bug 49097 - Downloaded file name not correct at citrix.com due to duplicate Content-Disposition
Summary: Downloaded file name not correct at citrix.com due to duplicate Content-Dispo...
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.6
: P2 Normal
Assignee: Nobody
URL: http://www.citrix.com/English/ss/down...
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2010-11-05 14:56 PDT by Vincent
Modified: 2013-07-30 10:54 PDT (History)
1 user (show)

See Also:


Attachments
info downloaded file + Download Manager window (96.04 KB, application/zip)
2010-11-05 14:57 PDT, Vincent
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vincent 2010-11-05 14:56:19 PDT
Safari 5.0.2 (6533.18.5, r71367)

On the URL above choose "Citrix Online plug-in for Mac" -> Download
Next window 'About the Download Manager' choose 'click here'  (not Click to download your file now')

Download starts and a file is downloaded named "CitrixOnlinePlug-in_full11_2.dmg"attachment
This is wrong! (should be just CitrixOnlinePlug-in_full11_2.dmg

If I do the same in Chrome, this file is downloaded correctly!
Comment 1 Vincent 2010-11-05 14:57:17 PDT
Created attachment 73124 [details]
info downloaded file + Download Manager window
Comment 2 Alexey Proskuryakov 2010-11-05 23:05:00 PDT
Caused by a broken server reply with duplicate Content-Disposition. But we should handle that like other browsers do.

HTTP/1.1 200 OK
Server: Apache
ETag: "3c8a69df64c7280ac382d40594dd0574:1285695062"
Last-Modified: Fri, 24 Sep 2010 13:35:03 GMT
Accept-Ranges: bytes
Content-Length: 26400730
Content-Type: application/octet-stream
Content-Disposition: attachment; filename="CitrixOnlinePlug-in_full11_2.dmg"
Date: Sat, 06 Nov 2010 05:51:58 GMT
Connection: keep-alive
Content-Disposition: attachment; filename="CitrixOnlinePlug-in_full11_2.dmg"
Comment 3 Alexey Proskuryakov 2010-11-05 23:05:54 PDT
<rdar://problem/8639019>
Comment 4 Alexey Proskuryakov 2010-11-05 23:11:25 PDT
Thank you for the report! Code that computes downloaded file name is outside open source WebKit, so I'm closing this bug as INVALID per our policy. It will continue to be tracked by Apple internally, and investigated by the team responsible for this code.
Comment 5 Alexey Proskuryakov 2013-07-30 10:54:54 PDT
This is fixed in OS X 10.7 and later.