Bug 49046 - Implement NP_RemoveProperty and NP_Enumerate
Summary: Implement NP_RemoveProperty and NP_Enumerate
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other OS X 10.5
: P2 Normal
Assignee: Anders Carlsson
Depends on:
Reported: 2010-11-04 18:47 PDT by Anders Carlsson
Modified: 2010-11-05 10:40 PDT (History)
1 user (show)

See Also:

Patch (9.30 KB, patch)
2010-11-04 18:51 PDT, Anders Carlsson
oliver: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Anders Carlsson 2010-11-04 18:47:45 PDT
Implement NP_RemoveProperty and NP_Enumerate
Comment 1 Anders Carlsson 2010-11-04 18:51:29 PDT
Created attachment 73028 [details]
Comment 2 WebKit Review Bot 2010-11-04 18:53:39 PDT
Attachment 73028 [details] did not pass style-queue:

Failed to run "['WebKitTools/Scripts/check-webkit-style', '--diff-files', u'LayoutTests/ChangeLog', u'LayoutTests/platform/mac-wk2/Skipped', u'WebKit2/ChangeLog', u'WebKit2/Shared/Plugins/NPObjectMessageReceiver.cpp', u'WebKit2/Shared/Plugins/NPObjectMessageReceiver.h', u'WebKit2/Shared/Plugins/NPObjectMessageReceiver.messages.in', u'WebKit2/Shared/Plugins/NPObjectProxy.cpp', u'WebKit2/Shared/Plugins/NPObjectProxy.h']" exit_code: 1
WebKit2/Shared/Plugins/NPObjectProxy.cpp:281:  NPObjectProxy::NP_RemoveProperty is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
WebKit2/Shared/Plugins/NPObjectProxy.cpp:286:  NPObjectProxy::NP_Enumerate is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Total errors found: 2 in 7 files

If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Oliver Hunt 2010-11-04 20:35:58 PDT
Comment on attachment 73028 [details]

Comment 4 Anders Carlsson 2010-11-05 10:40:44 PDT
Committed r71430: <http://trac.webkit.org/changeset/71430>