Implement NP_SetProperty
Created attachment 72875 [details] Patch
Attachment 72875 [details] did not pass style-queue: Failed to run "['WebKitTools/Scripts/check-webkit-style', '--diff-files', u'LayoutTests/ChangeLog', u'LayoutTests/platform/mac-wk2/Skipped', u'WebKit2/ChangeLog', u'WebKit2/Shared/Plugins/NPObjectMessageReceiver.cpp', u'WebKit2/Shared/Plugins/NPObjectMessageReceiver.h', u'WebKit2/Shared/Plugins/NPObjectMessageReceiver.messages.in', u'WebKit2/Shared/Plugins/NPObjectProxy.cpp', u'WebKit2/Shared/Plugins/NPObjectProxy.h']" exit_code: 1 WebKit2/Shared/Plugins/NPObjectProxy.cpp:237: NPObjectProxy::NP_SetProperty is incorrectly named. Don't use underscores in your identifier names. [readability/naming] [4] Total errors found: 1 in 7 files If any of these errors are false positives, please file a bug against check-webkit-style.
Comment on attachment 72875 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=72875&action=review > WebKit2/Shared/Plugins/NPObjectMessageReceiver.cpp:142 > + // And release the value. > + releaseNPVariantValue(&propertyValue); Makes me think we should have a smart pointer for NPVariant.
Committed r71273: <http://trac.webkit.org/changeset/71273>