Bug 48907 - Make it possible to delegate scrolling to the UI
Summary: Make it possible to delegate scrolling to the UI
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-03 05:40 PDT by Kenneth Rohde Christiansen
Modified: 2010-11-03 08:01 PDT (History)
2 users (show)

See Also:


Attachments
Patch (7.69 KB, patch)
2010-11-03 05:51 PDT, Kenneth Rohde Christiansen
kling: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kenneth Rohde Christiansen 2010-11-03 05:40:44 PDT
This is needed for client using a tiled scrolling implementation and thus delegating scrolling to the ui. In WebKit2 this is even more important as this cannot be implemented using the platformWidget().
Comment 1 Kenneth Rohde Christiansen 2010-11-03 05:51:24 PDT
Created attachment 72815 [details]
Patch

This is basically a clean up version of the patch that I showed Hyatt on irc yesterday:

<kenneth> dhyatt, proof of concept, feel free to comment: http://qt.pastebin.com/GHtt6xqM
<dhyatt> kenneth: yeah that looks pretty good
Comment 2 Andreas Kling 2010-11-03 06:25:27 PDT
Comment on attachment 72815 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=72815&action=review

r=me

> WebCore/page/FrameView.h:79
> +    virtual bool delegateScrolling();

I think we should call it shouldDelegateScrolling() here as well.
Comment 3 Kenneth Rohde Christiansen 2010-11-03 07:27:06 PDT
(In reply to comment #2)
> (From update of attachment 72815 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=72815&action=review
> 
> r=me
> 
> > WebCore/page/FrameView.h:79
> > +    virtual bool delegateScrolling();
> 
> I think we should call it shouldDelegateScrolling() here as well.

Everythign in FrameView and ScrollView is that way, like paintsEntireContents, avoidScrollbarCreation, etc.
Comment 4 Andreas Kling 2010-11-03 07:29:51 PDT
(In reply to comment #3)
> (In reply to comment #2)
> > (From update of attachment 72815 [details] [details])
> > View in context: https://bugs.webkit.org/attachment.cgi?id=72815&action=review
> > 
> > r=me
> > 
> > > WebCore/page/FrameView.h:79
> > > +    virtual bool delegateScrolling();
> > 
> > I think we should call it shouldDelegateScrolling() here as well.
> 
> Everythign in FrameView and ScrollView is that way, like paintsEntireContents, avoidScrollbarCreation, etc.

delegatesScrolling() then? *bikesheds*
I just don't like the imperative sound of "delegate scrolling."
Comment 5 Andreas Kling 2010-11-03 08:01:05 PDT
Committed r71239: <http://trac.webkit.org/changeset/71239>