Bug 48885 - Plugins specified via an OBJECT tag with a valid CLSID and a valid mime type don't load
Summary: Plugins specified via an OBJECT tag with a valid CLSID and a valid mime type ...
Status: RESOLVED DUPLICATE of bug 48757
Alias: None
Product: WebKit
Classification: Unclassified
Component: Plug-ins (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-02 16:30 PDT by Ananta Iyengar
Modified: 2010-11-02 16:36 PDT (History)
4 users (show)

See Also:


Attachments
Test case (432 bytes, text/html)
2010-11-02 16:30 PDT, Ananta Iyengar
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ananta Iyengar 2010-11-02 16:30:08 PDT
This bug was logged against Chromium originally http://code.google.com/p/chromium/issues/detail?id=61603

Please load the attached testcase in a nightly build of Safari or Chromium and you will see the problem.

This appears to have regressed in webkit revision 70748

2010-10-27  Andy Estes  <aestes@apple.com>

        Reviewed by Adam Barth.

        r66156 broke AtlasCT library, formerly affected http://map.d.co.il/
        https://bugs.webkit.org/show_bug.cgi?id=45679

        This patch removes WebKit's map of classid values to MIME types. It also
        changes the behavior of object elements to render fallback content when
        a non-empty classid attribute is specified, which is the behavior HTML5
        specifies when a UA encounters a classid it doesn't understand.

        Test: fast/replaced/object-with-non-empty-classid-triggers-fallback.html

        * html/HTMLObjectElement.cpp: Remove serviceTypeForClassId(),
        createClassIdToTypeMap(), and the ClassIdToTypeMap typedef.
        (WebCore::HTMLObjectElement::updateWidget): Do not call
        serviceTypeForClassId() when there is no type attribute, and render
        fallback content if the classid attribute is non-empty.
Comment 1 Ananta Iyengar 2010-11-02 16:30:39 PDT
Created attachment 72765 [details]
Test case
Comment 2 Andy Estes 2010-11-02 16:36:04 PDT

*** This bug has been marked as a duplicate of bug 48757 ***