Bug 48876 - Implement NP_HasProperty for NPObjectProxy
Summary: Implement NP_HasProperty for NPObjectProxy
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other OS X 10.5
: P2 Normal
Assignee: Anders Carlsson
Depends on:
Reported: 2010-11-02 15:11 PDT by Anders Carlsson
Modified: 2010-11-02 15:29 PDT (History)
1 user (show)

See Also:

Patch (6.40 KB, patch)
2010-11-02 15:16 PDT, Anders Carlsson
sam: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Anders Carlsson 2010-11-02 15:11:26 PDT
Implement NP_HasProperty for NPObjectProxy
Comment 1 Anders Carlsson 2010-11-02 15:16:11 PDT
Created attachment 72750 [details]
Comment 2 WebKit Review Bot 2010-11-02 15:18:12 PDT
Attachment 72750 [details] did not pass style-queue:

Failed to run "['WebKitTools/Scripts/check-webkit-style', '--diff-files', u'LayoutTests/ChangeLog', u'LayoutTests/platform/mac-wk2/Skipped', u'WebKit2/ChangeLog', u'WebKit2/Shared/Plugins/NPObjectMessageReceiver.cpp', u'WebKit2/Shared/Plugins/NPObjectMessageReceiver.h', u'WebKit2/Shared/Plugins/NPObjectMessageReceiver.messages.in', u'WebKit2/Shared/Plugins/NPObjectProxy.cpp', u'WebKit2/Shared/Plugins/NPObjectProxy.h']" exit_code: 1
WebKit2/Shared/Plugins/NPObjectProxy.cpp:174:  NPObjectProxy::NP_HasProperty is incorrectly named. Don't use underscores in your identifier names.  [readability/naming] [4]
Total errors found: 1 in 7 files

If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Anders Carlsson 2010-11-02 15:29:31 PDT
Committed r71178: <http://trac.webkit.org/changeset/71178>