Make RenderStyle::playState() return typed value and cleanup naming in Animation code"
Created attachment 72689 [details]
Comment on attachment 72689 [details]
View in context: https://bugs.webkit.org/attachment.cgi?id=72689&action=review
> - bool m_isSuspended;
> + bool m_suspended;
I think this is a step in the wrong direction, but I guess consistency is a good thing.
> - unsigned m_playState : 2;
> + EAnimPlayState m_playState : 2;
You need to keep this an unsigned bitfield. Enum bitfields are signed under MSVC, and that will screw up comparison operations. You should cast to EAnimPlayState in the getter.
Made change suggested by Adam and landed in http://trac.webkit.org/changeset/71125