Currently, this file is not very coherent in its content since some parts of it are written in an old-fashioned (not WebKit's coding-style compliant) way and some other, newer, parts are written in a completely different style.
On top of that, there's currently the "new trend" in the file of avoiding using an extra main loop in each test by just manually spinning the original main loop before trying to retrieve the accessible objects, which would be more than enough for the tests for properly work.
As a consequence, it would be nice to make some cleanup in this file to prepare it for further modifications, in a way so the whole file uses consistent style and patterns for the unit tests infrastructure.
I have a patch almost ready, attaching it in a while...
Adding Martin to CC, as he already showed interest on this matter
Created attachment 72510 [details]
Attaching patch proposal. Asking for review
Committed r71052: <http://trac.webkit.org/changeset/71052>