Bug 48665 - Changing a textarea value through JavaScript screws up undo for all textareas
Summary: Changing a textarea value through JavaScript screws up undo for all textareas
Status: RESOLVED DUPLICATE of bug 61340
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-29 12:51 PDT by Alexander Staubo
Modified: 2013-12-02 14:21 PST (History)
5 users (show)

See Also:


Attachments
Test case (277 bytes, text/html)
2010-10-29 12:51 PDT, Alexander Staubo
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Staubo 2010-10-29 12:51:33 PDT
Created attachment 72375 [details]
Test case

Consider two textarea fields in the same form. If a bit of JS code programmatically changes the value of one of the fields, the undo function will forget any undos for any part of the document. Test case attached which changes a value every 2 seconds.
Comment 1 Alexander Staubo 2010-10-29 12:52:17 PDT
Possibly related to bug # 14033.
Comment 2 Daniel Bates 2013-12-02 14:19:38 PST

*** This bug has been marked as a duplicate of bug 61340 ***
Comment 3 Daniel Bates 2013-12-02 14:21:12 PST
For completeness, I'm unable to reproduce this issue using the attached test case and nightly r159941 and Safari Version 7.0 (9537.71, 538+) on OS X Mavericks - 10.9 (13A603). In particular, I was able to both undo/redo changes made to both text areas despite the right text area updating its value on a 2 ms interval.