Bug 48619 - [Qt][WK2] SharedMemory uses two pages for one page request
Summary: [Qt][WK2] SharedMemory uses two pages for one page request
Status: RESOLVED DUPLICATE of bug 48520
Alias: None
Product: WebKit
Classification: Unclassified
Component: Platform (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-29 01:39 PDT by Balazs Kelemen
Modified: 2010-11-02 02:06 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Balazs Kelemen 2010-10-29 01:39:34 PDT
Our shared memory implementation tries to minimize the number of allocations trough recycling unused
mappings. This technique needs an extra word (word instead of a byte for aligning) in each mapping that
tracks that the memory is used or it has been released. The problem is that we ending up in allocating
an extra page if the client rounds up it's request to page size. This is the case of the VisitedLinkTable.
Comment 1 Balazs Kelemen 2010-10-29 01:50:30 PDT
Oh.... My patch asserts. The essence of that was to hack around
SharedMemory::systemPageSize to get back getpagesize() - extra_space
but there is an assert at VisitedLinkTable.cpp:60 - ASSERT(isPowerOf2(m_tableSize)); and this fails with the patch.
Grrrrrrr!
Comment 2 Balazs Kelemen 2010-11-02 02:06:55 PDT

*** This bug has been marked as a duplicate of bug 48520 ***