Bug 48594 - HTML5 Conformance Test failure: approved/xhtml5/img_border_percent.xhtml
Summary: HTML5 Conformance Test failure: approved/xhtml5/img_border_percent.xhtml
Status: RESOLVED DUPLICATE of bug 20226
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL: http://test.w3.org/html/tests/approve...
Keywords:
Depends on:
Blocks: 48575
  Show dependency treegraph
 
Reported: 2010-10-28 16:50 PDT by David Kilzer (:ddkilzer)
Modified: 2011-09-02 01:07 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Kilzer (:ddkilzer) 2010-10-28 16:50:07 PDT
The approved/xhtml5/img_border_percent.xhtml test fails with WebKit nightly build r70732 run in Safari 5.0.x.
Comment 1 Swapna P 2011-05-30 03:24:30 PDT
As per the HTML Spec http://www.w3schools.com/tags/att_img_border.asp, an image border can have only pixel value, It does not support % value. Therefore it is not a valid test case.

When defining border as pixels, ApplyPropertyWidth::applyValue() is called while for border percentage, ApplyPropertyDefault::applyValue() is called. 

As this seems to be an invalid test case, we should close this issue.
Comment 2 Mihnea Ovidenie 2011-07-27 00:45:32 PDT
This is a duplicate a bug 20226, that was solved in http://trac.webkit.org/changeset/91601.
Comment 3 Mihnea Ovidenie 2011-09-02 01:07:40 PDT

*** This bug has been marked as a duplicate of bug 20226 ***