Bug 48423 - Add info about installing dev. tools
Summary: Add info about installing dev. tools
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Website (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 48981 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-27 05:58 PDT by Orlando Leite
Modified: 2010-11-04 14:19 PDT (History)
4 users (show)

See Also:


Attachments
Add info about Java developer update in tools.html (1.19 KB, patch)
2010-10-27 05:58 PDT, Orlando Leite
no flags Details | Formatted Diff | Diff
Add Java developer update in tools webpage (1.70 KB, patch)
2010-10-28 19:07 PDT, Orlando Leite
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Orlando Leite 2010-10-27 05:58:52 PDT
Created attachment 72022 [details]
Add info about Java developer update in tools.html

JavaVM SDK is used to build the webkit. But It isn't related in http://webkit.org/building/tools.html.
It's ok until problems to build happen because Java SDK is not updated or not correctly.
I think this info should be added there.
Comment 1 Alexey Proskuryakov 2010-10-27 12:37:27 PDT
+<p>Download the last Java update for developers in <a href="http://connect.apple.com/">http://connect.apple.com/</a>. Without it, problems like 'JavaVM/jni.h: No such file or directory' can happen.</p>

This would be a good thing to mention. Please add a ChangeLog entry, and submit a patch for review: <http://webkit.org/coding/contributing.html>.

One note: it's not necessarily "last", it's "latest". Someone may have more comments about the wording.
Comment 2 Tony Gentilcore 2010-10-28 09:30:49 PDT
Drive-by wording suggestion:
+<li><p>Install Java for Mac OS X Developer Package</p>
+<p>Download and install the latest OS-appropriate "Java for Mac OS X Developer Package" from <a href="http://connect.apple.com/">http://connect.apple.com/</a> (located under Downloads > Java).</p>

If you aren't familiar with ChangeLogs, please see: http://webkit.org/coding/contributing.html#changelogs

If you use $ webkit-patch upload to upload the patch, it should automatically add an entry to http://trac.webkit.org/browser/trunk/WebKitSite/ChangeLog.
Comment 3 Orlando Leite 2010-10-28 19:07:00 PDT
Created attachment 72284 [details]
Add Java developer update in tools webpage

I think is correct now.
Comment 4 Adam Barth 2010-11-04 13:50:18 PDT
Comment on attachment 72284 [details]
Add Java developer update in tools webpage

Looks good.  Thanks.
Comment 5 Adam Barth 2010-11-04 13:51:15 PDT
*** Bug 48981 has been marked as a duplicate of this bug. ***
Comment 6 WebKit Commit Bot 2010-11-04 14:19:28 PDT
Comment on attachment 72284 [details]
Add Java developer update in tools webpage

Clearing flags on attachment: 72284

Committed r71356: <http://trac.webkit.org/changeset/71356>
Comment 7 WebKit Commit Bot 2010-11-04 14:19:33 PDT
All reviewed patches have been landed.  Closing bug.