Bug 48213 - [Qt] QtWebKit does not implement NPN_GetValueForURL, causing crashes of certain plugins
Summary: [Qt] QtWebKit does not implement NPN_GetValueForURL, causing crashes of certa...
Status: RESOLVED DUPLICATE of bug 34539
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Qt (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Linux
: P2 Major
Assignee: Nobody
URL: https://bugs.kde.org/show_bug.cgi?id=...
Keywords: Qt, QtTriaged
Depends on:
Blocks:
 
Reported: 2010-10-24 15:38 PDT by hansmbakker
Modified: 2011-06-08 08:25 PDT (History)
4 users (show)

See Also:


Attachments
Backtrace (15.93 KB, text/plain)
2010-10-24 15:38 PDT, hansmbakker
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description hansmbakker 2010-10-24 15:38:07 PDT
Created attachment 71699 [details]
Backtrace

Application: rekonq (0.6.1)
KDE Platform Version: 4.5.1 (KDE 4.5.1)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-22-generic x86_64
Distribution: Ubuntu maverick (development branch)

-- Information about the crash:
- What I was doing when the application crashed:
I visited a random page which has an embedded flash object
- Custom settings of the application:
I was trying lightspark from http://launchpad.net/~sssup/+archive/sssup-ppa instead of using adobe's flash plugin. The lightspark version is 0.4.4.3

The crash can be reproduced every time.

Also see my earlier bug report at KDE Bugzilla: https://bugs.kde.org/show_bug.cgi?id=250982
Comment 1 hansmbakker 2010-11-04 05:40:01 PDT
According to the author of Lightspark, "it crashes when trying to use NPN_GetValueForURL (see https://developer.mozilla.org/en/NPN_GetValueForURL).

Lightspark needs all the plugin API supported by Gecko 1.9 and WebKit does not implement all of them."

So:
- Webkit(-qt?) is not immune for crashing plugins. This is a bug the way I see it.
- Webkit does not support the full Mozilla plugin API. I think Lightspark should be able to cope with that, but it would be nice for developers if the API support would be compatible.
- Lightspark is not robust as in that it does dangerous assumptions.

Maybe the Webkit(-qt) developers can try to have Webkit not crash when a plugin crashes?
Comment 2 Benjamin Poulain 2011-01-28 19:05:22 PST
Please follow http://trac.webkit.org/wiki/QtWebKitBugs when reporing bugs (missing Qt keyword).

(In reply to comment #1)
> Maybe the Webkit(-qt) developers can try to have Webkit not crash when a plugin crashes?

Unfortunatelly, this is not as easy as it sounds.
Comment 3 Dawit A. 2011-06-08 07:48:56 PDT
NPN_GetValueForURL has already been implemented as it was a requirement to get java applets to work as well. See https://bugs.webkit.org/show_bug.cgi?id=34539.
Unfortunately it is not available in the version of QtWebKit bundled with Qt. You have to use QtWebKit v2.1 and up from git. 

Can someone with karma close this bug report as already fixed ?
Comment 4 Luiz Agostini 2011-06-08 08:25:34 PDT

*** This bug has been marked as a duplicate of bug 34539 ***