WebKit Bugzilla
New
Browse
Log In
×
Sign in with GitHub
or
Remember my login
Create Account
·
Forgot Password
Forgotten password account recovery
RESOLVED FIXED
48192
[Cairo] Remove PlatformRefPtrCairo
https://bugs.webkit.org/show_bug.cgi?id=48192
Summary
[Cairo] Remove PlatformRefPtrCairo
Martin Robinson
Reported
2010-10-23 11:15:19 PDT
PlatformRefPtrCairo is unecessary. It should be replaced by a RefPtr specialization. See this mailing list thread for more details:
http://comments.gmane.org/gmane.os.opendarwin.webkit.devel/14529
This is the first step toward removing PlatformRefPtr entirely.
Attachments
Remove PlatformRefPtrCairo
(20.31 KB, patch)
2010-10-23 12:05 PDT
,
Martin Robinson
no flags
Details
Formatted Diff
Diff
Patch also including RefPtrCair.cpp and RefPtrCairo.h
(32.00 KB, patch)
2010-10-25 13:22 PDT
,
Martin Robinson
abarth
: review+
Details
Formatted Diff
Diff
Show Obsolete
(1)
View All
Add attachment
proposed patch, testcase, etc.
Martin Robinson
Comment 1
2010-10-23 12:05:37 PDT
Created
attachment 71651
[details]
Remove PlatformRefPtrCairo
Brent Fulgham
Comment 2
2010-10-25 10:11:50 PDT
I heartily approve of this change. This should also resolve some of Darin's concerns about the use of the term 'Platform' in the RefPtr name. Let's get it approved and landed!
Martin Robinson
Comment 3
2010-10-25 13:22:20 PDT
Created
attachment 71789
[details]
Patch also including RefPtrCair.cpp and RefPtrCairo.h My previous patch did not include RefPtrCairo.h and RefPtrCairo.cpp. I could not convince webkit-patch to include them for some reason, so I've had to roll the patch by hand.
WebKit Review Bot
Comment 4
2010-10-25 13:25:36 PDT
Attachment 71789
[details]
did not pass style-queue: Failed to run "['WebKitTools/Scripts/check-webkit-style']" exit_code: 1 WebCore/platform/graphics/cairo/RefPtrCairo.cpp:33: Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons. [readability/comparison_to_zero] [5] WebCore/platform/graphics/cairo/RefPtrCairo.cpp:39: Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons. [readability/comparison_to_zero] [5] WebCore/platform/graphics/cairo/RefPtrCairo.cpp:45: Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons. [readability/comparison_to_zero] [5] WebCore/platform/graphics/cairo/RefPtrCairo.cpp:51: Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons. [readability/comparison_to_zero] [5] WebCore/platform/graphics/cairo/RefPtrCairo.cpp:57: Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons. [readability/comparison_to_zero] [5] WebCore/platform/graphics/cairo/RefPtrCairo.cpp:63: Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons. [readability/comparison_to_zero] [5] WebCore/platform/graphics/cairo/RefPtrCairo.cpp:69: Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons. [readability/comparison_to_zero] [5] WebCore/platform/graphics/cairo/RefPtrCairo.cpp:75: Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons. [readability/comparison_to_zero] [5] WebCore/platform/graphics/cairo/RefPtrCairo.cpp:82: Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons. [readability/comparison_to_zero] [5] WebCore/platform/graphics/cairo/RefPtrCairo.cpp:88: Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons. [readability/comparison_to_zero] [5] Total errors found: 10 in 18 files If any of these errors are false positives, please file a bug against check-webkit-style.
Martin Robinson
Comment 5
2010-10-25 13:31:51 PDT
(In reply to
comment #4
)
> WebCore/platform/graphics/cairo/RefPtrCairo.cpp:33: Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons. [readability/comparison_to_zero] [5]
I believe these are all false positives. When making the patch I discovered that LIKELY will not accept a pointer as an argument. It requires something which evaluates to a boolean.
WebKit Review Bot
Comment 6
2010-10-25 13:58:33 PDT
Attachment 71651
[details]
did not build on gtk: Build output:
http://queues.webkit.org/results/4819001
Martin Robinson
Comment 7
2010-11-02 19:24:06 PDT
Committed
r71204
: <
http://trac.webkit.org/changeset/71204
>
Note
You need to
log in
before you can comment on or make changes to this bug.
Top of Page
Format For Printing
XML
Clone This Bug