Bug 48148 - ASSERT while viewing Google C++ style guide
Summary: ASSERT while viewing Google C++ style guide
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other OS X 10.5
: P2 Normal
Assignee: Adam Barth
URL:
Keywords:
: 47305 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-22 12:44 PDT by Adam Barth
Modified: 2010-10-22 14:00 PDT (History)
6 users (show)

See Also:


Attachments
Patch (3.41 KB, patch)
2010-10-22 12:48 PDT, Adam Barth
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Barth 2010-10-22 12:44:08 PDT
ASSERT while viewing Google C++ style guide
Comment 1 Adam Barth 2010-10-22 12:48:31 PDT
Created attachment 71586 [details]
Patch
Comment 2 Eric Seidel (no email) 2010-10-22 12:51:20 PDT
Comment on attachment 71586 [details]
Patch

OK.  I assume finishParsing() does nothing else we'd need here?
Comment 3 Tony Gentilcore 2010-10-22 12:57:50 PDT
Nice. Thanks for the fix.
Comment 4 Tony Gentilcore 2010-10-22 13:00:42 PDT
*** Bug 47305 has been marked as a duplicate of this bug. ***
Comment 5 Adam Barth 2010-10-22 13:06:28 PDT
close() calls finishParsing() for us.  That how it ... finishes parsing.  :)
Comment 6 WebKit Commit Bot 2010-10-22 13:06:32 PDT
Comment on attachment 71586 [details]
Patch

Clearing flags on attachment: 71586

Committed r70327: <http://trac.webkit.org/changeset/70327>
Comment 7 WebKit Commit Bot 2010-10-22 13:06:37 PDT
All reviewed patches have been landed.  Closing bug.
Comment 8 WebKit Review Bot 2010-10-22 14:00:21 PDT
http://trac.webkit.org/changeset/70327 might have broken GTK Linux 64-bit Debug
The following tests are not passing:
mathml/presentation/fenced-mi.xhtml
mathml/presentation/subsup.xhtml