Bug 48124 - large brackets and other extend operators showing as missing glyph
Summary: large brackets and other extend operators showing as missing glyph
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: MathML (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC Windows 7
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on: 134154
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-22 05:12 PDT by David Carlisle
Modified: 2016-04-19 02:10 PDT (History)
5 users (show)

See Also:


Attachments
fragment of screenshot showing webkit rendering (6.83 KB, image/png)
2010-10-22 05:12 PDT, David Carlisle
no flags Details
side by side rendering with webkit and firefox no stix characters display in webkit (283.34 KB, image/png)
2010-10-22 13:09 PDT, David Carlisle
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Carlisle 2010-10-22 05:12:45 PDT
Created attachment 71551 [details]
fragment of screenshot showing webkit rendering 

Using a webkit nightly on windows 7 
c:\WebKit-r70091\WebKit.exe
large brackets are not being displayed. I assume this is because the stix fonts are not being detected, although I have v1.0 installed in the usual windows/fonts location

looking at the existing webkit mathml demo
https://bug-43818-attachments.webkit.org/attachment.cgi?id=64056
I see the attached display


/c/windows/fonts
$ ls -l STIX*
-rwx------+ 1 SYSTEM Domain Users 170988 2010-04-30 04:06 STIXGeneralItalic.otf
-rwx------+ 1 SYSTEM Domain Users  17696 2010-04-30 04:06 STIXIntDReg.otf
-rwx------+ 1 SYSTEM Domain Users  16688 2010-04-30 04:06 STIXIntSmBol.otf
-rwx------+ 1 SYSTEM Domain Users  17456 2010-04-30 04:06 STIXIntSmReg.otf
-rwx------+ 1 SYSTEM Domain Users  16924 2010-04-30 04:06 STIXIntUpBol.otf
-rwx------+ 1 SYSTEM Domain Users  17224 2010-04-30 04:06 STIXIntUpDReg.otf
-rwx------+ 1 SYSTEM Domain Users  16976 2010-04-30 04:06 STIXIntUpReg.otf
-rwx------+ 1 SYSTEM Domain Users  17124 2010-04-30 04:06 STIXIntUpSmBol.otf
-rwx------+ 1 SYSTEM Domain Users  17256 2010-04-30 04:06 STIXIntUpSmReg.otf
-rwx------+ 1 SYSTEM Domain Users  39780 2010-04-30 04:06 STIXNonUniBolIta.otf
-rwx------+ 1 SYSTEM Domain Users  44628 2010-04-30 04:06 STIXNonUniIta.otf
-rwx------+ 1 SYSTEM Domain Users  13598 2010-04-30 04:06 STIXSizFiveSymReg.otf
-rwx------+ 1 SYSTEM Domain Users  12454 2010-04-30 04:06 STIXSizFourSymBol.otf
-rwx------+ 1 SYSTEM Domain Users  12738 2010-04-30 04:06 STIXSizOneSymBol.otf
-rwx------+ 1 SYSTEM Domain Users  19076 2010-04-30 04:06 STIXSizOneSymReg.otf
-rwx------+ 1 SYSTEM Domain Users  12466 2010-04-30 04:06 STIXSizThreeSymBol.otf
-rwx------+ 1 SYSTEM Domain Users  15774 2010-04-30 04:06 STIXSizThreeSymReg.otf
-rwx------+ 1 SYSTEM Domain Users  12402 2010-04-30 04:06 STIXSizTwoSymBol.otf
-rwx------+ 1 SYSTEM Domain Users  15656 2010-04-30 04:06 STIXSizTwoSymReg.otf
-rwx------+ 1 SYSTEM Domain Users  22008 2010-04-30 04:06 STIXVar.otf
-rwx------+ 1 SYSTEM Domain Users  14988 2010-04-30 04:06 STIXVarBol.otf
Comment 1 François Sausset 2010-10-22 05:51:02 PDT
It seems that you have not all the STIX fonts installed.
I don't see:
STIXGeneral.otf
STIXGeneralBol.otf
STIXGeneralBolIta.otf

Or is it just the copied list that is incomplete?
Comment 2 David Carlisle 2010-10-22 05:59:59 PDT
(In reply to comment #1)
> It seems that you have not all the STIX fonts installed.
> I don't see:
> STIXGeneral.otf
> STIXGeneralBol.otf
> STIXGeneralBolIta.otf
> 

sorry for that I probably messed up while copying the listing.

$ ls STIX* | wc -l
29

davidc@RUBY /c/windows/fonts
$ ls STIX*
STIXGeneral.otf        STIXIntUpDReg.otf      STIXSizFourSymReg.otf
STIXGeneralBol.otf     STIXIntUpReg.otf       STIXSizOneSymBol.otf
STIXGeneralBolIta.otf  STIXIntUpSmBol.otf     STIXSizOneSymReg.otf
STIXGeneralItalic.otf  STIXIntUpSmReg.otf     STIXSizThreeSymBol.otf
STIXIntDBol.otf        STIXNonUni.otf         STIXSizThreeSymReg.otf
STIXIntDReg.otf        STIXNonUniBol.otf      STIXSizTwoSymBol.otf
STIXIntSmBol.otf       STIXNonUniBolIta.otf   STIXSizTwoSymReg.otf
STIXIntSmReg.otf       STIXNonUniIta.otf      STIXVar.otf
STIXIntUpBol.otf       STIXSizFiveSymReg.otf  STIXVarBol.otf
STIXIntUpDBol.otf      STIXSizFourSymBol.otf

To make sure I (re) unpacked the stix zip file and copied the fonts in to place, and see no change in the rendering.
Comment 3 François Sausset 2010-10-22 06:14:40 PDT
OK.

It seems indeed that it is a font detection problem. However, I don't know from where it comes from.

The use of STIX fonts is done by CSS: font-family: STIXGeneral;
It should be platform independent.
Strange!

Are the STIX fonts well detected by other applications?
If not, it should be an incompatibility between STIX fonts and windows 7, not specific to webkit.
Comment 4 David Carlisle 2010-10-22 06:59:50 PDT
(In reply to comment #3)
>
> 
> Are the STIX fonts well detected by other applications?

I've been doing some html5/mathml testing (as we just finished mathml3 yesterday)
so I have so many nightly or alpha/beta versions of browsers on this machine I'm not sure what works where anymore. I shall try to produce a reproducible test case showing the stix fonts being used in something and not being used in the webkit nightly, and report back. Just to confirm: it is stix v1, not stix beta that webkit is targeting?
Comment 5 François Sausset 2010-10-22 07:04:17 PDT
WebKit is targeting STIX fonts v1.
It has been tested on the mac platform and , if I'm not wrong, on the GTK one.
Comment 6 David Carlisle 2010-10-22 13:09:26 PDT
Created attachment 71590 [details]
side by side rendering with webkit and firefox no stix characters display in webkit
Comment 7 David Carlisle 2010-10-22 13:10:44 PDT
Sorry I misclassified this problem as mathml in the initial report. I can reproduce just using html/css/stix 

The table at

http://www.w3.org/2003/entities/2007doc/1D5.html

has in each cell a png image and under that the character rendered with css

span.stix {
 font-size: 125%;
 font-family: STIXGeneral, STIXGeneral-Italic, STIXGeneral-Bold, STIXGeneral-BoldItalic;
 background-color: #FFFFDD; 

The attached screenshot shows side by side rendering with FF 4.6 beta and webkit nightly All the characters render in Firefox 9 also, but not shown, in IE9, Chrome 7 and Opera 10.7) but none of then show in webkit.
Comment 8 Dave Barton 2012-10-17 15:18:25 PDT
The second attachment is a duplicate of bug 24230 regarding Unicode non-BMP characters. I don't know about the first attachment. I think Firefox may use its own characters for operator extension characters, since it displays them somehow on my plain Vista emulator *without* any STIX fonts installed. The extension glyphs are in STIXSizeOneSym if that's installed. Can other applications like Character Map or Notepad (or other - I'm not a Windows guy) find these e.g. U+239B to U+23AE characters, assuming you have STIXSizeOneSym installed?

Note also that Ancil George <ancil0504@gmail.com> found the stretched operators rendered ok in a recent Chrome Canary, presumably using STIXSizeOneSym, but they're invisible in the WebKit.exe nightly (and hence probably Safari on Windows ?).
Comment 9 A George 2012-10-27 03:14:02 PDT
Chrome Canary(Version 24.0.1308.0 canary) renders all the characters in the link
http://www.w3.org/2003/entities/2007doc/1D5.html well.

The latest nightly Webkit.exe doesn't render any of the characters as mentioned by Davide Carlisle.

Test environment: Windows 7 SP1 with STIX V1.1.0
Comment 10 Frédéric Wang (:fredw) 2016-03-14 03:24:32 PDT
I'm classifying this back to MathML for now and making it depends on bug 134154.

Note that for MathML, STIXGeneral is obsolete you should use e.g. Latin Modern Math or STIX Math (release candidate).

Anyway, I'm not sure what's the status of the Windows port, I did not test it and I don't think there are nightly builds any more...
Comment 11 Frédéric Wang (:fredw) 2016-04-19 02:10:30 PDT
I'm closing this bug as it seems to be an old report specific to the Windows port (and to Chrome).