Following the rename in WebCore, QWebPage::ViewportConfiguration should be renamed to QWebPage::ViewportArguments, and QWebPage::viewportConfigurationForSize() should be renamed to QWebPage::viewportAttributesForSize()
Created attachment 70035 [details]
Comment on attachment 70035 [details]
Clearing flags on attachment: 70035
Committed r69331: <http://trac.webkit.org/changeset/69331>
All reviewed patches have been landed. Closing bug.
Shouldn't WebKit2 API be changed as well (on trunk)?
(In reply to comment #4)
> Shouldn't WebKit2 API be changed as well (on trunk)?
The WebKit2 API will change as soon as we have the WebKit2 C API approved and integrated. This doesn't depend on our public release.
Revision r69331 cherry-picked into qtwebkit-2.1 with commit 15761d2 <http://gitorious.org/webkit/qtwebkit/commit/15761d2>
This breaks Symbian, as the .def files are now again, out of sync, and need to be re-frozen.