The latest draft of the writing mode spec kills the block-flow property and just makes writing-mode the property to use. Update all the code to match the new draft.
Created attachment 69968 [details]
Attachment 69968 [details] did not pass style-queue:
Failed to run "['WebKitTools/Scripts/check-webkit-style']" exit_code: 1
WebCore/rendering/style/SVGRenderStyle.h:354: _writingMode is incorrectly named. Don't use underscores in your identifier names. [readability/naming] 
Total errors found: 1 in 39 files
If any of these errors are false positives, please file a bug against check-webkit-style.
Comment on attachment 69968 [details]
View in context: https://bugs.webkit.org/attachment.cgi?id=69968&action=review
> +static int resolveToPhysicalProperty(TextDirection direction, WritingMode blockDirection, LogicalBoxSide logicalSide, const int* properties)
I’d rename the variable too.
> +static int resolveToPhysicalProperty(WritingMode blockDirection, LogicalExtent logicalSide, const int* properties)
> +int CSSProperty::resolveDirectionAwareProperty(int propertyID, TextDirection direction, WritingMode blockDirection)
> +# Standards values from CSS3
Fixed in r69220.
http://trac.webkit.org/changeset/69220 might have broken SnowLeopard Intel Release (Tests)
(In reply to comment #5)
> http://trac.webkit.org/changeset/69220 might have broken SnowLeopard Intel Release (Tests)
This failure is still on the bots. Investigating.
Maybe just needs a new baseline?
Landed updated baseline in http://trac.webkit.org/changeset/69263
Mr. Hyatt, was that correct?