Bug 47252 - [V8] Web Inspector: stack information is inconsistent between console.trace and runtime errors.
Summary: [V8] Web Inspector: stack information is inconsistent between console.trace a...
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (Deprecated) (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Yury Semikhatsky
URL:
Keywords:
: 63175 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-06 02:34 PDT by Yury Semikhatsky
Modified: 2013-04-05 13:00 PDT (History)
12 users (show)

See Also:


Attachments
Screenshot (16.37 KB, image/png)
2010-10-06 02:34 PDT, Yury Semikhatsky
no flags Details
Patch (22.30 KB, patch)
2010-10-06 06:36 PDT, Yury Semikhatsky
pfeldman: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yury Semikhatsky 2010-10-06 02:34:08 PDT
Created attachment 69907 [details]
Screenshot

Web Inspector: stack information is inconsistent between console.trace and runtime errors. Line numbers match, but the format of the output does not. Also stack formatter ignores //@ sourceURL value for uncaught exceptions(unlike Error.stack formatter).
Comment 1 Yury Semikhatsky 2010-10-06 06:36:05 PDT
Created attachment 69930 [details]
Patch
Comment 2 Yury Semikhatsky 2010-10-13 07:47:17 PDT
Committed r69662
Comment 3 James Robinson 2010-10-13 12:11:07 PDT
This appears to be causing failures on the chromium windows canary and is skipped on mac and linux.  Would you mind taking a look? http://test-results.appspot.com/dashboards/flakiness_dashboard.html#showExpectations=true&useWebKitCanary=true&tests=inspector%2Fconsole-trace-in-eval.html%2Cinspector%2Fconsole-uncaught-exception-in-eval.html
Comment 4 Yury Semikhatsky 2010-10-14 03:02:41 PDT
(In reply to comment #3)
> This appears to be causing failures on the chromium windows canary and is skipped on mac and linux.  Would you mind taking a look? http://test-results.appspot.com/dashboards/flakiness_dashboard.html#showExpectations=true&useWebKitCanary=true&tests=inspector%2Fconsole-trace-in-eval.html%2Cinspector%2Fconsole-uncaught-exception-in-eval.html

Initially I committed wrong expectations. Fixed in a follow-up change. The test is passing.
Comment 5 Pavel Podivilov 2011-06-23 01:32:04 PDT
"//@ sourceURL" value is still ignored in JSC. See inspector/console/console-trace-in-eval.html expectations.
Comment 6 Pavel Podivilov 2011-06-23 01:32:32 PDT
*** Bug 63175 has been marked as a duplicate of this bug. ***
Comment 7 Timothy Hatcher 2013-04-05 13:00:44 PDT
Chromium and V8 have left the building. Won't fix.