Bug 47231 - [chromium] Video-related compositor tests failing in DumpRenderTree
Summary: [chromium] Video-related compositor tests failing in DumpRenderTree
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-10-05 17:22 PDT by Kenneth Russell
Modified: 2011-02-17 20:49 PST (History)
8 users (show)

See Also:


Attachments
Patch (82.77 KB, patch)
2011-02-17 15:48 PST, Mihai Parparita
tkent: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kenneth Russell 2010-10-05 17:22:24 PDT
The following video-related compositor tests are failing in DumpRenderTree when run with --enable-accelerated-compositing. I haven't triaged the failures but suspect that they all have the same root cause.

compositing/geometry/clipped-video-controller.html
compositing/geometry/video-fixed-scrolling.html
compositing/geometry/video-opacity-overlay.html
compositing/layers-inside-overflow-scroll.html
compositing/overflow/overflow-compositing-descendant.html
compositing/overflow/scroll-ancestor-update.html
compositing/reflections/load-video-in-reflection.html
compositing/self-painting-layers.html
compositing/self-painting-layers2.html
compositing/video/video-background-color.html
compositing/video/video-poster.html
Comment 1 Mihai Parparita 2011-02-15 14:39:48 PST
It looks like all these tests fail because they can't load the test video file: http://svn.webkit.org/repository/webkit/trunk/LayoutTests/compositing/resources/video.mp4

(not sure what makes it special, Safari, QuickTime and VLC can play it just fine)
Comment 2 Kenneth Russell 2011-02-15 15:00:36 PST
(In reply to comment #1)
> It looks like all these tests fail because they can't load the test video file: http://svn.webkit.org/repository/webkit/trunk/LayoutTests/compositing/resources/video.mp4
> 
> (not sure what makes it special, Safari, QuickTime and VLC can play it just fine)

Hmm. Thinking about this more, we only include certain decoders in the Google Chrome branded build, not Chromium. We are probably missing the appropriate decoder in DRT.
Comment 3 Mihai Parparita 2011-02-15 15:10:27 PST
(In reply to comment #2)
> Hmm. Thinking about this more, we only include certain decoders in the Google Chrome branded build, not Chromium. We are probably missing the appropriate decoder in DRT.

The tests in media/ have findMediaFile (http://trac.webkit.org/browser/trunk/LayoutTests/media/media-file.js) which switches to ogg if that's playable. Does it make sense to do that here too?
Comment 4 Kenneth Russell 2011-02-15 15:13:49 PST
(In reply to comment #3)
> (In reply to comment #2)
> > Hmm. Thinking about this more, we only include certain decoders in the Google Chrome branded build, not Chromium. We are probably missing the appropriate decoder in DRT.
> 
> The tests in media/ have findMediaFile (http://trac.webkit.org/browser/trunk/LayoutTests/media/media-file.js) which switches to ogg if that's playable. Does it make sense to do that here too?

Maybe. vrk, scherkus, can you confirm?
Comment 5 Andrew Scherkus 2011-02-15 15:24:14 PST
That's most likely the issue.

To verify try building DRT with GYP_DEFINES="ffmpeg_branding=Chrome" and see if the tests run (or at least don't crap out because we don't support .mp4)
Comment 6 Mihai Parparita 2011-02-15 15:25:46 PST
(In reply to comment #5)
> That's most likely the issue.
> 
> To verify try building DRT with GYP_DEFINES="ffmpeg_branding=Chrome" and see if the tests run (or at least don't crap out because we don't support .mp4)

Actually, the video.mp4 file doesn't seem to play in Chrome dev channel (on Mac) either, which presumably should be able to handle the h264 codec.
Comment 7 Andrew Scherkus 2011-02-15 17:15:13 PST
yeah it's an mpeg-4 as opposed to h.264 video :(
Comment 8 Mihai Parparita 2011-02-15 17:30:10 PST
(In reply to comment #7)
> yeah it's an mpeg-4 as opposed to h.264 video :(

For the compositor tests I don't think we care about specific codecs, just that there's a video element. Is there a codec that we could use that would work on all platforms/ports, or do we have to include both ogg and h264 or mpeg-4 files?
Comment 9 Andrew Scherkus 2011-02-15 17:31:15 PST
probably best/safest to do something like in LayoutTests/media
Comment 10 Mihai Parparita 2011-02-17 15:48:39 PST
Created attachment 82872 [details]
Patch
Comment 11 Mihai Parparita 2011-02-17 15:49:23 PST
Tests still fail with image diffs even with this fix, filed bug 54694 about that.
Comment 12 Kent Tamura 2011-02-17 17:14:36 PST
Comment on attachment 82872 [details]
Patch

LGTM except ChangeLog diff starting at line 3.
Comment 13 Mihai Parparita 2011-02-17 20:48:53 PST
Committed r78951: <http://trac.webkit.org/changeset/78951>
Comment 14 Mihai Parparita 2011-02-17 20:49:56 PST
(In reply to comment #12)
> (From update of attachment 82872 [details])
> LGTM except ChangeLog diff starting at line 3.

That was just a bad diff since there were two consecutive entries with my name on them. Once I rebaselined to ToT it started at line 1.