Bug 47175 - -webkit-transform makes (unrelated) element flicker under certain conditions
Summary: -webkit-transform makes (unrelated) element flicker under certain conditions
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
: 44110 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-10-05 06:55 PDT by Dieter Komendera
Modified: 2017-01-22 15:05 PST (History)
3 users (show)

See Also:


Attachments
test case (1.81 KB, text/html)
2010-10-05 06:55 PDT, Dieter Komendera
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dieter Komendera 2010-10-05 06:55:36 PDT
Created attachment 69779 [details]
test case

We've seen some strange flickering occur in Safari (and latest WebKit nightly), where on one of our sites the logo started flickering while -webkit-transitions were performing somewhere on the page. The issues doesn't exist with Chrome. We've created a striped down example which reproduces the issue.

In the test case, hover over the boxes labeled "1" and "2" to start transitions. While the transition is performing, the green box at the bottom is flickering.
We've only encountered the issue with a combination of position (absolute), z-index (not equal 0) and the value of the text-indent (in the test case case lower than -1800px or higher than 1877px) of the h1.

Test case is attached.
Comment 1 Simon Fraser (smfr) 2010-10-05 13:31:05 PDT
You should always combine text-indent: -hugeval with overflow:hidden.

The huge text-indent causes a tiled layer. Tiled layers are known to flicker.
Comment 2 Simon Fraser (smfr) 2010-12-06 10:53:48 PST
<rdar://problem/6474145>
Comment 3 Simon Fraser (smfr) 2010-12-07 14:09:04 PST
*** Bug 44110 has been marked as a duplicate of this bug. ***
Comment 4 Dieter Komendera 2012-10-09 09:24:16 PDT
I can't reproduce this anymore with the attached test case on Safari Version 6.0.1 (8536.26.14, 537+) r130635. Resolved?