Bug 47172 - [Qt]Windowless flash plugin is not rendered in Symbian
Summary: [Qt]Windowless flash plugin is not rendered in Symbian
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Plug-ins (show other bugs)
Version: 528+ (Nightly build)
Hardware: S60 Hardware S60 3rd edition
: P2 Normal
Assignee: mike.zraly
URL:
Keywords: Qt
Depends on:
Blocks:
 
Reported: 2010-10-05 06:30 PDT by Dinu Jacob
Modified: 2010-10-08 04:45 PDT (History)
5 users (show)

See Also:


Attachments
proposed patch for Symbian-specific plugin code (1.60 KB, patch)
2010-10-05 09:43 PDT, mike.zraly
akling: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dinu Jacob 2010-10-05 06:30:19 PDT
Flash in the url https://bugs.webkit.org/enter_bug.cgi?product=WebKit is not displayed.
Comment 1 mike.zraly 2010-10-05 07:57:57 PDT
The problem addressed by this bug currently shows up regardless of whether we have a windowed or window-less plugin.  The issue is that the Symbian PluginView implementation sets its m_windowRect and m_clipRect members before the platform widget gets created in the platformStart() method, so the plugin always has a height and width of zero.
Comment 2 mike.zraly 2010-10-05 09:43:41 PDT
Created attachment 69797 [details]
proposed patch for Symbian-specific plugin code
Comment 3 Suresh Voruganti 2010-10-05 10:38:10 PDT
Added the dependency to 39121 Master bug for QtWebkit 2.1 as the fix is needed for QtWebkit 2.1
Comment 4 Andreas Kling 2010-10-06 22:28:04 PDT
Comment on attachment 69797 [details]
proposed patch for Symbian-specific plugin code

View in context: https://bugs.webkit.org/attachment.cgi?id=69797&action=review

r=me

> WebCore/ChangeLog:8
> +        No new tests. (OOPS!)

Oops indeed, please remove this line.
Comment 5 Simon Hausmann 2010-10-07 02:12:50 PDT
Committed r69282: <http://trac.webkit.org/changeset/69282>
Comment 6 Ademar Reis 2010-10-08 04:45:21 PDT
Revision r69282 cherry-picked into qtwebkit-2.1 with commit 009aaea <http://gitorious.org/webkit/qtwebkit/commit/009aaea>