Bug 4714 - NodeIterator does not handle exceptions from the filter function (affects Acid3)
Summary: NodeIterator does not handle exceptions from the filter function (affects Acid3)
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: DOM (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Darin Adler
URL:
Keywords:
: 16743 16744 (view as bug list)
Depends on:
Blocks: Acid3
  Show dependency treegraph
 
Reported: 2005-08-28 11:16 PDT by Darin Adler
Modified: 2019-02-06 09:03 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Darin Adler 2005-08-28 11:16:32 PDT
Looking at the NodeIterator code, it's clear that it doesn't do the right thing in the presence of exceptions. 
If the filter function raises an exception, the standard says that the exception should be propagated to the 
caller of nextNode or previousNode.

But our NodeIterator implementation does not attempt to do that. Also, it calls the filter function from the 
"node removed" hook; it's not at all clear if it's appropriate to do so, nor what happens if the filter function 
raises an exception in that case.
Comment 1 Darin Adler 2008-01-08 13:02:43 PST
*** Bug 16744 has been marked as a duplicate of this bug. ***
Comment 2 Darin Adler 2008-01-08 13:04:08 PST
*** Bug 16743 has been marked as a duplicate of this bug. ***
Comment 3 Darin Adler 2008-01-08 13:04:35 PST
Need to make sure when fixing this that we pass both test cases from Acid3, the one in bug 16743 and the one in bug 16744.
Comment 4 Darin Adler 2008-01-08 22:52:21 PST
Bug 3492 now has a patch that addresses this.
Comment 5 Darin Adler 2008-02-08 02:36:07 PST
Committed revision 30089.
Comment 6 Lucas Forschler 2019-02-06 09:03:11 PST
Mass moving XML DOM bugs to the "DOM" Component.