Bug 47058 - -webkit-transform blocks -webkit-mask
Summary: -webkit-transform blocks -webkit-mask
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL: http://cssdesk.com/fYzmf
Keywords: NeedsReduction
Depends on:
Reported: 2010-10-03 09:14 PDT by Dimtrie
Modified: 2012-11-22 21:15 PST (History)
5 users (show)

See Also:

local html example of the bug (3.71 KB, text/html)
2010-10-03 09:14 PDT, Dimtrie
no flags Details
Zip file containing test of bug. (196.18 KB, application/octet-stream)
2011-02-25 12:41 PST, Fady Samuel
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dimtrie 2010-10-03 09:14:58 PDT
Created attachment 69589 [details]
local html example of the bug

Overview: More detailed restatement of summary.

When hovering over an element that triggers the hover function and sets a transform in motion, it blocks the -webkit-mask and thus it disappears.

triggering the bug:
1)go to: 
or look at the attachment

2) hover over the div element

Actual Result: mask disappears while transform is in motion. It appears again when the animation is done ( let your cursor rest for about 2 seconds on the div )

Expected Results: The mask should hide the overflowing content, even when the transform is in motion.

Build Date & Platform: Webkit-svn-r68887 build 01-10-2010 on Windows Vista

Build 2006-08-10 on Mac OS 10.4.3
Additional Builds and Platforms: Whether or not the bug takes place on other platforms (or browsers, if applicable).

Additional Builds and Platforms: As far as i know, it occurs on every os and platform (send the bug to paul-irish, he asked me to file it here)

Additional Information: Tried to solve the bug with an overlaying div element, with again a mask. Gave the same result. Example http://cssdesk.com/j3JcH
Comment 1 Simon Fraser (smfr) 2010-12-21 11:59:27 PST
Can you make a very simple testcase with just one element? It's not clear to me from this (cool!) testcase what the issue is.
Comment 2 Fady Samuel 2011-02-25 12:41:10 PST
Created attachment 83862 [details]
Zip file containing test of bug.

Notice that once scaling is applied to the image, the mask no longer works.
Comment 3 Simon Fraser (smfr) 2011-02-25 13:29:51 PST
Your testcase works perfectly for me. What OS and browser are you testing with?
Comment 4 Dirk Schulze 2012-11-21 22:17:42 PST
Works for me as well.