Bug 47017 - REGRESSION (r63957): fast/text/backslash-to-yen-sign-euc.html fails on Mac
Summary: REGRESSION (r63957): fast/text/backslash-to-yen-sign-euc.html fails on Mac
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Text (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar, LayoutTestFailure, Regression
Depends on:
Blocks:
 
Reported: 2010-10-01 14:07 PDT by Adam Roben (:aroben)
Modified: 2010-10-12 01:34 PDT (History)
7 users (show)

See Also:


Attachments
Patch v1 (11.58 KB, patch)
2010-10-11 00:49 PDT, Shinichiro Hamaji
no flags Details | Formatted Diff | Diff
Patch v2 (168.72 KB, patch)
2010-10-11 10:15 PDT, Shinichiro Hamaji
ap: review+
ap: commit-queue-
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Roben (:aroben) 2010-10-01 14:07:23 PDT
http://trac.webkit.org/changeset/63957 updated the Mac results for fast/text/backslash-to-yen-sign-euc.html, introducing many failures. You can now see lots of examples of "expected: backslash, actual: \x{A5}" in the test.
Comment 1 Adam Roben (:aroben) 2010-10-01 14:08:33 PDT
<rdar://problem/8504199>
Comment 2 Shinichiro Hamaji 2010-10-11 00:49:20 PDT
Created attachment 70427 [details]
Patch v1
Comment 3 Shinichiro Hamaji 2010-10-11 00:55:17 PDT
Sorry, I should have updated the description of the test cases. We changed the behavior of how fonts in control element are considered. So, these changes are intended (actually, I thought I changed the descriptions... Maybe I've made some mistakes).

This change won't change the expectations of Windows, Qt, Gtk, and Chromium. I'll fix them soon after I'll land this patch.
Comment 4 Alexey Proskuryakov 2010-10-11 08:48:54 PDT
The patch doesn't include updated pixel results.
Comment 5 Shinichiro Hamaji 2010-10-11 10:15:38 PDT
Created attachment 70442 [details]
Patch v2
Comment 6 Shinichiro Hamaji 2010-10-11 10:16:04 PDT
(In reply to comment #4)
> The patch doesn't include updated pixel results.

Oops. Updated.
Comment 7 Alexey Proskuryakov 2010-10-11 10:20:37 PDT
Comment on attachment 70442 [details]
Patch v2

OK. Please update the ChangeLog to list pixel results, too.
Comment 8 Shinichiro Hamaji 2010-10-12 01:01:06 PDT
Committed r69564: <http://trac.webkit.org/changeset/69564>
Comment 9 WebKit Review Bot 2010-10-12 01:34:12 PDT
http://trac.webkit.org/changeset/69564 might have broken Qt Linux Release