WebKit Bugzilla
New
Browse
Log In
×
Sign in with GitHub
or
Remember my login
Create Account
·
Forgot Password
Forgotten password account recovery
RESOLVED FIXED
46802
Web Inspector: extract consoleMessages related stuff from populateScriptObjects into separate function.
https://bugs.webkit.org/show_bug.cgi?id=46802
Summary
Web Inspector: extract consoleMessages related stuff from populateScriptObjec...
Ilya Tikhonovsky
Reported
2010-09-29 05:40:44 PDT
this is a part of Inspector protocol sanitization activity. We want to populate console messages only if it is required by frontend.
Attachments
[patch] initial version.
(9.74 KB, patch)
2010-09-29 07:47 PDT
,
Ilya Tikhonovsky
no flags
Details
Formatted Diff
Diff
[patch] second iteration
(12.18 KB, patch)
2010-10-04 01:45 PDT
,
Ilya Tikhonovsky
yurys
: review-
Details
Formatted Diff
Diff
[patch] third iteration.
(20.21 KB, patch)
2010-10-04 08:20 PDT
,
Ilya Tikhonovsky
pfeldman
: review-
Details
Formatted Diff
Diff
[patch] next iteration.
(10.80 KB, patch)
2010-10-15 05:23 PDT
,
Ilya Tikhonovsky
no flags
Details
Formatted Diff
Diff
[patch] next iteration.
(9.48 KB, patch)
2010-10-15 07:05 PDT
,
Ilya Tikhonovsky
no flags
Details
Formatted Diff
Diff
Show Obsolete
(4)
View All
Add attachment
proposed patch, testcase, etc.
Ilya Tikhonovsky
Comment 1
2010-09-29 07:47:57 PDT
Created
attachment 69195
[details]
[patch] initial version.
Ilya Tikhonovsky
Comment 2
2010-09-29 08:26:13 PDT
Comment on
attachment 69195
[details]
[patch] initial version. the idea was changed.
Ilya Tikhonovsky
Comment 3
2010-10-04 01:45:15 PDT
Created
attachment 69605
[details]
[patch] second iteration
Yury Semikhatsky
Comment 4
2010-10-04 02:25:02 PDT
Comment on
attachment 69605
[details]
[patch] second iteration View in context:
https://bugs.webkit.org/attachment.cgi?id=69605&action=review
> WebCore/inspector/InspectorController.cpp:127 > +static const char* const consoleMessagesNotificationsStateName = "consoleMessagesNotificationsEnabled";
Should we move this constants into a class/namespace InspectorSettingNames instead of using *StateName suffix?
> WebCore/inspector/InspectorController.cpp:162 > + , m_consoleMessagesNotifications(false)
m_consoleMessagesNotifications -> m_consoleMessagesNotificationsEnabled
> WebCore/inspector/InspectorController.cpp:603 > + m_consoleMessagesNotifications = false;
This will be called only on close of the detached window. When attached window is closed only disconnectFrontend will be invoked. r- for this.
> WebCore/inspector/InspectorController.h:150 > + void setConsoleMessagesNotificationsEnabled(bool enabled);
should be private
Ilya Tikhonovsky
Comment 5
2010-10-04 08:20:45 PDT
Created
attachment 69635
[details]
[patch] third iteration.
Pavel Feldman
Comment 6
2010-10-04 13:28:55 PDT
Comment on
attachment 69635
[details]
[patch] third iteration. View in context:
https://bugs.webkit.org/attachment.cgi?id=69635&action=review
> WebCore/inspector/InspectorController.h:362 > + bool m_consoleMessagesNotificationsEnabled;
This seems to be a new kind of flag that reflects the front-end state. It should vanish on front-end disconnect. We already have way too many settings, states for sessions, application, etc. Should we create structs with descriptive names for them already?
Ilya Tikhonovsky
Comment 7
2010-10-15 05:23:13 PDT
Created
attachment 70855
[details]
[patch] next iteration.
Yury Semikhatsky
Comment 8
2010-10-15 05:40:03 PDT
Comment on
attachment 70855
[details]
[patch] next iteration. View in context:
https://bugs.webkit.org/attachment.cgi?id=70855&action=review
> WebCore/inspector/InspectorController.cpp:625 > + unsigned messageCount = m_consoleMessages.size();
unsigned -> size_t
> WebCore/inspector/InspectorState.cpp:54 > + registerBoolean(consoleMessagesNotificationsEnabled, false, "consoleMessagesNotifications", (const char*)0);
There should be a single place where constants like "consoleMessagesNotifications" are declared.
Ilya Tikhonovsky
Comment 9
2010-10-15 07:05:37 PDT
Created
attachment 70865
[details]
[patch] next iteration. New version of patch which is less generic. It'd be better to implement the generic version later with help of InspectorGenerator just for strict arguments check.
Eric Seidel (no email)
Comment 10
2010-10-15 07:05:40 PDT
Comment on
attachment 70855
[details]
[patch] next iteration. Cleared Yury Semikhatsky's review+ from obsolete
attachment 70855
[details]
so that this bug does not appear in
http://webkit.org/pending-commit
.
WebKit Commit Bot
Comment 11
2010-10-15 08:20:47 PDT
Comment on
attachment 70865
[details]
[patch] next iteration. Clearing flags on attachment: 70865 Committed
r69853
: <
http://trac.webkit.org/changeset/69853
>
WebKit Commit Bot
Comment 12
2010-10-15 08:20:53 PDT
All reviewed patches have been landed. Closing bug.
Note
You need to
log in
before you can comment on or make changes to this bug.
Top of Page
Format For Printing
XML
Clone This Bug