Bug 46750 - Rename the MarginInfo members and functions.
Summary: Rename the MarginInfo members and functions.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: PC OS X 10.5
: P2 Normal
Assignee: Dave Hyatt
URL:
Keywords:
Depends on:
Blocks: 46123
  Show dependency treegraph
 
Reported: 2010-09-28 13:22 PDT by Dave Hyatt
Modified: 2010-09-28 13:46 PDT (History)
1 user (show)

See Also:


Attachments
Patch (20.78 KB, patch)
2010-09-28 13:23 PDT, Dave Hyatt
sam: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Hyatt 2010-09-28 13:22:19 PDT
Rename the MarginInfo members and functions to be block-flow independent.
Comment 1 Dave Hyatt 2010-09-28 13:23:02 PDT
Created attachment 69094 [details]
Patch
Comment 2 WebKit Review Bot 2010-09-28 13:23:55 PDT
Attachment 69094 [details] did not pass style-queue:

Failed to run "['WebKitTools/Scripts/check-webkit-style']" exit_code: 1
WebCore/rendering/RenderBlock.cpp:95:  Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]
WebCore/rendering/RenderBlock.cpp:101:  Boolean expressions that span multiple lines should have their operators on the left side of the line instead of the right side.  [whitespace/operators] [4]
WebCore/rendering/RenderBlock.cpp:101:  Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]
WebCore/rendering/RenderBlock.cpp:102:  Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]
WebCore/rendering/RenderBlock.cpp:1500:  Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]
WebCore/rendering/RenderBlock.cpp:1539:  Boolean expressions that span multiple lines should have their operators on the left side of the line instead of the right side.  [whitespace/operators] [4]
WebCore/rendering/RenderBlock.cpp:1539:  An else should appear on the same line as the preceding }  [whitespace/newline] [4]
WebCore/rendering/RenderBlock.cpp:1708:  Tests for true/false, null/non-null, and zero/non-zero should all be done without equality comparisons.  [readability/comparison_to_zero] [5]
Total errors found: 8 in 3 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 3 Dave Hyatt 2010-09-28 13:28:31 PDT
Landed in r68556.